caif: fix memory leak in cfctrl_linkup_request()
Priority LOW 24CWE-401Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-401.
Summary
In the Linux kernel, the following vulnerability has been resolved: caif: fix memory leak in cfctrl_linkup_request() When linktype is unknown or kzalloc failed in cfctrl_linkup_request(), pkt is not released. Add release process to error path.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00149 4th percentileScored 2026-11-07
Fix Fixed Linux (Linux): 4.14.303, 4.19.270, 5.4.229 +5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.35 and later | 4.14.303, 4.19.270, 5.4.229, 5.10.163, 5.15.87, 6.0.19, 6.1.5, 6.2 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.35 and later Fixed in 4.14.303, 4.19.270, 5.4.229, 5.10.163, 5.15.87, 6.0.19, 6.1.5, 6.2 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.35 to before 4.14.303; 4.15 to before 4.19.270; 4.20 to before 5.4.229; 5.5 to before 5.10.163; 5.11 to before 5.15.87; 5.16 to before 6.0.19; 6.1 to before 6.1.5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.2:rc1:*:*:*:*:*:* | 6.2 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.2:rc2:*:*:*:*:*:* | 6.2 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.35 to before 4.14.303; 4.15 to before 4.19.270; 4.20 to before 5.4.229; 5.5 to before 5.10.163; 5.11 to before 5.15.87; 5.16 to before 6.0.19; 6.1 to before 6.1.5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.2:rc1:*:*:*:*:*:* Versions 6.2 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.2:rc2:*:*:*:*:*:* Versions 6.2 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.14.303, 4.19.270, 5.4.229, 5.10.163, 5.15.87, 6.0.19, 6.1.5, 6.2
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-53330
- 2026-10-03 Alias added: GHSA-pxv4-xvvx-325j
References
Patch 8
- https://git.kernel.org/stable/c/badea57569db04b010e922e29a7aaf40a979a70b
- https://git.kernel.org/stable/c/3acf3783a84cbdf0c9f8cf2f32ee9c49af93a2da
- https://git.kernel.org/stable/c/33df9c5d5e2a18c70f5f5f3c2757d654c1b6ffa3
- https://git.kernel.org/stable/c/84b2cc7b36b7f6957d307fb3d01603f93cb2d655
- https://git.kernel.org/stable/c/dc1bc903970bdf63ca40ab923d3ccb765da9a8d9
- https://git.kernel.org/stable/c/1dddeceb26002cfea4c375e92ac6498768dc7349
- https://git.kernel.org/stable/c/3ad47c8aa5648226184415e4a0cb1bf67ffbfd48
- https://git.kernel.org/stable/c/fe69230f05897b3de758427b574fc98025dfc907
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2023-53330 · CVE Program
- CVE-2023-53330 · NVD
- FIRST EPSS
- GHSA-pxv4-xvvx-325j · GitHub Advisory Database · CC BY 4.0
- CVE-2023-53330 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences