cassini: Fix a memory leak in the error handling path of cas_init_one()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-401.
Summary
In the Linux kernel, the following vulnerability has been resolved: cassini: Fix a memory leak in the error handling path of cas_init_one() cas_saturn_firmware_init() allocates some memory using vmalloc(). This memory is freed in the .remove() function but not it the error handling path of the probe. Add the missing vfree() to avoid a memory leak, should an error occur.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.28 and later | 4.14.316, 4.19.284, 5.4.244, 5.10.181, 5.15.113, 6.1.30, 6.3.4, 6.4 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.28 and later Fixed in 4.14.316, 4.19.284, 5.4.244, 5.10.181, 5.15.113, 6.1.30, 6.3.4, 6.4 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.28 to before 4.14.316; 4.15 to before 4.19.284; 4.20 to before 5.4.244; 5.5 to before 5.10.181; 5.11 to before 5.15.113; 5.16 to before 6.1.30; 6.2 to before 6.3.4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc1:*:*:*:*:*:* | 6.4 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc2:*:*:*:*:*:* | 6.4 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.28 to before 4.14.316; 4.15 to before 4.19.284; 4.20 to before 5.4.244; 5.5 to before 5.10.181; 5.11 to before 5.15.113; 5.16 to before 6.1.30; 6.2 to before 6.3.4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc1:*:*:*:*:*:* Versions 6.4 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc2:*:*:*:*:*:* Versions 6.4 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.14.316, 4.19.284, 5.4.244, 5.10.181, 5.15.113, 6.1.30, 6.3.4, 6.4
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-53435
- 2026-10-03 Alias added: GHSA-qjh2-vwwm-cqj6
References
Patch 8
- https://git.kernel.org/stable/c/11c0ed097a874156957b515d0ba7e356142eab87
- https://git.kernel.org/stable/c/60d8e8b88087d68e10c8991a0f6733fa2f963ff0
- https://git.kernel.org/stable/c/e20105d967ab5b53ff50a0e5991fe37324d2ba20
- https://git.kernel.org/stable/c/dc61f7582cc92d547d02e141cd66f5d1f4ed8012
- https://git.kernel.org/stable/c/234e744d86bd95b381d24546df2dba72804e0219
- https://git.kernel.org/stable/c/172146c26f0c1b86ab4e9ebffc7e06f04229fa17
- https://git.kernel.org/stable/c/b8b1a667744741fa7807b09a12797a27f14f3fac
- https://git.kernel.org/stable/c/412cd77a2c24b191c65ea53025222418db09817c
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2023-53435 · CVE Program
- CVE-2023-53435 · NVD
- FIRST EPSS
- GHSA-qjh2-vwwm-cqj6 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-53435 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences