wifi: iwlwifi: mvm: don't trust firmware n_channels
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: wifi: iwlwifi: mvm: don't trust firmware n_channels If the firmware sends us a corrupted MCC response with n_channels much larger than the command response can be, we might copy far too much (uninitialized) memory and even crash if the n_channels is large enough to make it run out of the one page allocated for the FW response. Fix that by checking the lengths. Doing a < comparison would be sufficient, but the firmware should be doing it correctly, so check more strictly.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.1 and later | 5.4.244, 5.10.181, 5.15.113, 6.1.30, 6.3.4, 6.4 | Patch available | CNA |
- Linux VendorLinux Affected 4.1 and later Fixed in 5.4.244, 5.10.181, 5.15.113, 6.1.30, 6.3.4, 6.4 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.1 to before 5.4.244; 5.5 to before 5.10.181; 5.11 to before 5.15.113; 5.16 to before 6.1.30; 6.2 to before 6.3.4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc1:*:*:*:*:*:* | 6.4 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc2:*:*:*:*:*:* | 6.4 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.1 to before 5.4.244; 5.5 to before 5.10.181; 5.11 to before 5.15.113; 5.16 to before 6.1.30; 6.2 to before 6.3.4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc1:*:*:*:*:*:* Versions 6.4 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc2:*:*:*:*:*:* Versions 6.4 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.244, 5.10.181, 5.15.113, 6.1.30, 6.3.4, 6.4
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Not affected: 3 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2023-53589
- 2026-10-03 Alias added: GHSA-fh27-hfj9-ccqv
- 2026-10-16 CISA SSVC decision points changed
- 2026-10-16 Priority changed: LOW → MEDIUM
References
Patch 6
- https://git.kernel.org/stable/c/e519a404a5bbba37693cb10fa61794a5fce4fd9b
- https://git.kernel.org/stable/c/d0d39bed9e95f27a246be91c5929254ac043ed30
- https://git.kernel.org/stable/c/05ad5a4d421ce65652fcb24d46b7e273130240d6
- https://git.kernel.org/stable/c/557ba100d8cf3661ff8d71c0b4a2cba8db555ec2
- https://git.kernel.org/stable/c/c176f03350954b795322de0bfe1d7b514db41f45
- https://git.kernel.org/stable/c/682b6dc29d98e857e6ca4bbc077c7dc2899b7473
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2023-53589 · CVE Program
- CVE-2023-53589 · NVD
- FIRST EPSS
- GHSA-fh27-hfj9-ccqv · GitHub Advisory Database · CC BY 4.0
- CVE-2023-53589 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences