CakePHP SecurityComponent cross form submission issue
Priority LOW 38Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
Prior to versions 2.4.8 and 1.3.18, forms secured by SecurityComponent could be submitted to any action without triggering SecurityComponent’s tampering protection. If an application contained multiple POST forms to manipulate the same models, it could be vulnerable to mass assignment issues.
Why it matters now
Fix Fixed cakephp/cakephp (Packagist): 2.4.8, 1.3.18
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | cakephp/cakephp (Packagist) | 2.0.0 to before 2.4.8 | 2.4.8 | Patch available | GHSA-j9q2-f9q7-jhgq |
| — | cakephp/cakephp (Packagist) | 1.3.0 to before 1.3.18 | 1.3.18 | Patch available | GHSA-j9q2-f9q7-jhgq |
- cakephp/cakephp (Packagist) Vendor— Affected 2.0.0 to before 2.4.8 Fixed in 2.4.8 Patch available GHSA-j9q2-f9q7-jhgq
- cakephp/cakephp (Packagist) Vendor— Affected 1.3.0 to before 1.3.18 Fixed in 1.3.18 Patch available GHSA-j9q2-f9q7-jhgq
Remediation
- Fix · GHSA-j9q2-f9q7-jhgq cakephp/cakephp (Packagist) Fixed in 2.4.8 Advisory →
- Fix · GHSA-j9q2-f9q7-jhgq cakephp/cakephp (Packagist) Fixed in 1.3.18 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-j9q2-f9q7-jhgq
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences