CakePHP vulnerable to Denial of Service attack through XML payloads
Priority LOW 38Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
RequestHandlerComponent had a vulnerability that would allow well crafted requests to create a denial of service attack. RequestHandlerComponent leverages `Xml::build()` which allows reading local files. We recommend that all applications using RequestHandlerComponent upgrade, or disable parsing XML payloads.
Why it matters now
Fix Fixed cakephp/cakephp (Packagist): 3.0.6, 2.0.99, 2.1.99 +5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | cakephp/cakephp (Packagist) | 3.0.0 to before 3.0.6 | 3.0.6 | Patch available | GHSA-q79m-c546-2g63 |
| — | cakephp/cakephp (Packagist) | 2.0.0 to before 2.0.99 | 2.0.99 | Patch available | GHSA-q79m-c546-2g63 |
| — | cakephp/cakephp (Packagist) | 2.1.0 to before 2.1.99 | 2.1.99 | Patch available | GHSA-q79m-c546-2g63 |
| — | cakephp/cakephp (Packagist) | 2.2.0 to before 2.2.99 | 2.2.99 | Patch available | GHSA-q79m-c546-2g63 |
| — | cakephp/cakephp (Packagist) | 2.3.0 to before 2.3.99 | 2.3.99 | Patch available | GHSA-q79m-c546-2g63 |
| — | cakephp/cakephp (Packagist) | 2.4.0 to before 2.4.99 | 2.4.99 | Patch available | GHSA-q79m-c546-2g63 |
| — | cakephp/cakephp (Packagist) | 2.5.0 to before 2.5.90 | 2.5.90 | Patch available | GHSA-q79m-c546-2g63 |
| — | cakephp/cakephp (Packagist) | 2.6.0 to before 2.6.6 | 2.6.6 | Patch available | GHSA-q79m-c546-2g63 |
- cakephp/cakephp (Packagist) Vendor— Affected 3.0.0 to before 3.0.6 Fixed in 3.0.6 Patch available GHSA-q79m-c546-2g63
- cakephp/cakephp (Packagist) Vendor— Affected 2.0.0 to before 2.0.99 Fixed in 2.0.99 Patch available GHSA-q79m-c546-2g63
- cakephp/cakephp (Packagist) Vendor— Affected 2.1.0 to before 2.1.99 Fixed in 2.1.99 Patch available GHSA-q79m-c546-2g63
- cakephp/cakephp (Packagist) Vendor— Affected 2.2.0 to before 2.2.99 Fixed in 2.2.99 Patch available GHSA-q79m-c546-2g63
- cakephp/cakephp (Packagist) Vendor— Affected 2.3.0 to before 2.3.99 Fixed in 2.3.99 Patch available GHSA-q79m-c546-2g63
- cakephp/cakephp (Packagist) Vendor— Affected 2.4.0 to before 2.4.99 Fixed in 2.4.99 Patch available GHSA-q79m-c546-2g63
- cakephp/cakephp (Packagist) Vendor— Affected 2.5.0 to before 2.5.90 Fixed in 2.5.90 Patch available GHSA-q79m-c546-2g63
- cakephp/cakephp (Packagist) Vendor— Affected 2.6.0 to before 2.6.6 Fixed in 2.6.6 Patch available GHSA-q79m-c546-2g63
Remediation
- Fix · GHSA-q79m-c546-2g63 cakephp/cakephp (Packagist) Fixed in 3.0.6 Advisory →
- Fix · GHSA-q79m-c546-2g63 cakephp/cakephp (Packagist) Fixed in 2.0.99 Advisory →
- Fix · GHSA-q79m-c546-2g63 cakephp/cakephp (Packagist) Fixed in 2.1.99 Advisory →
- Fix · GHSA-q79m-c546-2g63 cakephp/cakephp (Packagist) Fixed in 2.2.99 Advisory →
- Fix · GHSA-q79m-c546-2g63 cakephp/cakephp (Packagist) Fixed in 2.3.99 Advisory →
- Fix · GHSA-q79m-c546-2g63 cakephp/cakephp (Packagist) Fixed in 2.4.99 Advisory →
- Fix · GHSA-q79m-c546-2g63 cakephp/cakephp (Packagist) Fixed in 2.5.90 Advisory →
- Fix · GHSA-q79m-c546-2g63 cakephp/cakephp (Packagist) Fixed in 2.6.6 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-q79m-c546-2g63
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences