Read the docs
TI-2023-30672 Aliases GHSA-p76f-wr22-4rv6

CakePHP vulnerable to Remote File Inclusion through View template name manipulation

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

CakePHP 2.x prior to 2.0.99, 2.1.99, 2.2.99, 2.3.99, 2.4.99, 2.5.99, 2.6.12, and 2.7.6 and 3.x prior to 3.0.15 and 3.1.4 is vulnerable to Remote File Inclusion through View template name manipulation.

Why it matters now

Fix Fixed cakephp/cakephp (Packagist): 2.0.99, 2.1.99, 2.2.99 +7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—cakephp/cakephp (Packagist)2.0.0 to before 2.0.992.0.99Patch availableGHSA-p76f-wr22-4rv6
—cakephp/cakephp (Packagist)2.1.0 to before 2.1.992.1.99Patch availableGHSA-p76f-wr22-4rv6
—cakephp/cakephp (Packagist)2.2.0 to before 2.2.992.2.99Patch availableGHSA-p76f-wr22-4rv6
—cakephp/cakephp (Packagist)2.3.0 to before 2.3.992.3.99Patch availableGHSA-p76f-wr22-4rv6
—cakephp/cakephp (Packagist)2.4.0 to before 2.4.992.4.99Patch availableGHSA-p76f-wr22-4rv6
—cakephp/cakephp (Packagist)2.5.0 to before 2.5.992.5.99Patch availableGHSA-p76f-wr22-4rv6
—cakephp/cakephp (Packagist)2.6.0 to before 2.6.122.6.12Patch availableGHSA-p76f-wr22-4rv6
—cakephp/cakephp (Packagist)2.7.0 to before 2.7.62.7.6Patch availableGHSA-p76f-wr22-4rv6
—cakephp/cakephp (Packagist)3.0.0 to before 3.0.153.0.15Patch availableGHSA-p76f-wr22-4rv6
—cakephp/cakephp (Packagist)3.1.0 to before 3.1.43.1.4Patch availableGHSA-p76f-wr22-4rv6
  • cakephp/cakephp (Packagist) Vendor— Affected 2.0.0 to before 2.0.99 Fixed in 2.0.99 Patch available GHSA-p76f-wr22-4rv6
  • cakephp/cakephp (Packagist) Vendor— Affected 2.1.0 to before 2.1.99 Fixed in 2.1.99 Patch available GHSA-p76f-wr22-4rv6
  • cakephp/cakephp (Packagist) Vendor— Affected 2.2.0 to before 2.2.99 Fixed in 2.2.99 Patch available GHSA-p76f-wr22-4rv6
  • cakephp/cakephp (Packagist) Vendor— Affected 2.3.0 to before 2.3.99 Fixed in 2.3.99 Patch available GHSA-p76f-wr22-4rv6
  • cakephp/cakephp (Packagist) Vendor— Affected 2.4.0 to before 2.4.99 Fixed in 2.4.99 Patch available GHSA-p76f-wr22-4rv6
  • cakephp/cakephp (Packagist) Vendor— Affected 2.5.0 to before 2.5.99 Fixed in 2.5.99 Patch available GHSA-p76f-wr22-4rv6
  • cakephp/cakephp (Packagist) Vendor— Affected 2.6.0 to before 2.6.12 Fixed in 2.6.12 Patch available GHSA-p76f-wr22-4rv6
  • cakephp/cakephp (Packagist) Vendor— Affected 2.7.0 to before 2.7.6 Fixed in 2.7.6 Patch available GHSA-p76f-wr22-4rv6
  • cakephp/cakephp (Packagist) Vendor— Affected 3.0.0 to before 3.0.15 Fixed in 3.0.15 Patch available GHSA-p76f-wr22-4rv6
  • cakephp/cakephp (Packagist) Vendor— Affected 3.1.0 to before 3.1.4 Fixed in 3.1.4 Patch available GHSA-p76f-wr22-4rv6

Remediation

  • Fix · GHSA-p76f-wr22-4rv6 cakephp/cakephp (Packagist) Fixed in 2.0.99 Advisory →
  • Fix · GHSA-p76f-wr22-4rv6 cakephp/cakephp (Packagist) Fixed in 2.1.99 Advisory →
  • Fix · GHSA-p76f-wr22-4rv6 cakephp/cakephp (Packagist) Fixed in 2.2.99 Advisory →
  • Fix · GHSA-p76f-wr22-4rv6 cakephp/cakephp (Packagist) Fixed in 2.3.99 Advisory →
  • Fix · GHSA-p76f-wr22-4rv6 cakephp/cakephp (Packagist) Fixed in 2.4.99 Advisory →
  • Fix · GHSA-p76f-wr22-4rv6 cakephp/cakephp (Packagist) Fixed in 2.5.99 Advisory →
  • Fix · GHSA-p76f-wr22-4rv6 cakephp/cakephp (Packagist) Fixed in 2.6.12 Advisory →
  • Fix · GHSA-p76f-wr22-4rv6 cakephp/cakephp (Packagist) Fixed in 2.7.6 Advisory →
  • Fix · GHSA-p76f-wr22-4rv6 cakephp/cakephp (Packagist) Fixed in 3.0.15 Advisory →
  • Fix · GHSA-p76f-wr22-4rv6 cakephp/cakephp (Packagist) Fixed in 3.1.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-p76f-wr22-4rv6

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences