CakePHP vulnerable to Cross-site Scripting in some development error pages
Priority LOW 38Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
CakePHP 3.4 prior to 3.4.14, 3.5 prior to 3.5.17, and 3.6 prior to 3.6.4 contains a cross-site-scripting (XSS) vulnerability in the development only `missing route` and `duplicate named route` error pages.
Why it matters now
Fix Fixed cakephp/cakephp (Packagist): 3.4.14, 3.5.17, 3.6.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | cakephp/cakephp (Packagist) | 3.4.0 to before 3.4.14 | 3.4.14 | Patch available | GHSA-xwhj-pqcg-8rcr |
| — | cakephp/cakephp (Packagist) | 3.5.0 to before 3.5.17 | 3.5.17 | Patch available | GHSA-xwhj-pqcg-8rcr |
| — | cakephp/cakephp (Packagist) | 3.6.0 to before 3.6.4 | 3.6.4 | Patch available | GHSA-xwhj-pqcg-8rcr |
- cakephp/cakephp (Packagist) Vendor— Affected 3.4.0 to before 3.4.14 Fixed in 3.4.14 Patch available GHSA-xwhj-pqcg-8rcr
- cakephp/cakephp (Packagist) Vendor— Affected 3.5.0 to before 3.5.17 Fixed in 3.5.17 Patch available GHSA-xwhj-pqcg-8rcr
- cakephp/cakephp (Packagist) Vendor— Affected 3.6.0 to before 3.6.4 Fixed in 3.6.4 Patch available GHSA-xwhj-pqcg-8rcr
Remediation
- Fix · GHSA-xwhj-pqcg-8rcr cakephp/cakephp (Packagist) Fixed in 3.4.14 Advisory →
- Fix · GHSA-xwhj-pqcg-8rcr cakephp/cakephp (Packagist) Fixed in 3.5.17 Advisory →
- Fix · GHSA-xwhj-pqcg-8rcr cakephp/cakephp (Packagist) Fixed in 3.6.4 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-xwhj-pqcg-8rcr
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences