Read the docs
TI-2023-30674 Aliases GHSA-m4ch-rfv5-x5g3

git2-rs fails to verify SSH keys by default

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

The git2 and libgit2-sys crates are Rust wrappers around the [libgit2](https://libgit2.org/) C library. It was discovered that libgit2 1.5.0 and below did not verify SSH host keys when establishing an SSH connection, exposing users of the library to Man-In-the-Middle attacks. The libgit2 team assigned [CVE-2023-22742](https://github.com/libgit2/libgit2/security/advisories/GHSA-8643-3wh5-rmjq) to this vulnerability. The following versions of the libgit2-sys Rust crate have been released: * libgit2-sys 0.14.2, updating the underlying libgit2 C library to version 1.5.1. * libgit2-sys 0.13.5, updating the underlying libgit2 C library to version 1.4.5. A new git2 crate version has also been released, 0.16.1. This version only bumps its libgit2-sys dependency to ensure no vulnerable libgit2-sys versions are used, but contains no code changes: if you update the libgit2-sys version there is no need to also update the git2 crate version. [You can learn more about this vulnerability in libgit2's advisory](https://github.com/libgit2/libgit2/security/advisories/GHSA-8643-3wh5-rmjq)

Why it matters now

Fix Fixed libgit2-sys (crates.io): 0.14.2, 0.13.5git2 (crates.io): 0.16.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—libgit2-sys (crates.io)0.14.0 to before 0.14.20.14.2Patch availableGHSA-m4ch-rfv5-x5g3
—libgit2-sys (crates.io)before 0.13.50.13.5Patch availableGHSA-m4ch-rfv5-x5g3
—git2 (crates.io)before 0.16.10.16.1Patch availableGHSA-m4ch-rfv5-x5g3
  • libgit2-sys (crates.io) Vendor— Affected 0.14.0 to before 0.14.2 Fixed in 0.14.2 Patch available GHSA-m4ch-rfv5-x5g3
  • libgit2-sys (crates.io) Vendor— Affected before 0.13.5 Fixed in 0.13.5 Patch available GHSA-m4ch-rfv5-x5g3
  • git2 (crates.io) Vendor— Affected before 0.16.1 Fixed in 0.16.1 Patch available GHSA-m4ch-rfv5-x5g3

Remediation

  • Fix · GHSA-m4ch-rfv5-x5g3 libgit2-sys (crates.io) Fixed in 0.14.2 Advisory →
  • Fix · GHSA-m4ch-rfv5-x5g3 libgit2-sys (crates.io) Fixed in 0.13.5 Advisory →
  • Fix · GHSA-m4ch-rfv5-x5g3 git2 (crates.io) Fixed in 0.16.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-m4ch-rfv5-x5g3

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences