Read the docs
TI-2023-30698 Aliases GHSA-cp47-r258-q626

Vega vulnerable to arbitrary code execution when clicking href links

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

Vega is vulnerable to arbitrary code execution when clicking href links. Versions 5.4.1 and 4.5.1 contain a patch.

Why it matters now

Fix Fixed vega (npm): 5.4.1, 4.5.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—vega (npm)5.0.0 to before 5.4.15.4.1Patch availableGHSA-cp47-r258-q626
—vega (npm)before 4.5.14.5.1Patch availableGHSA-cp47-r258-q626
  • vega (npm) Vendor— Affected 5.0.0 to before 5.4.1 Fixed in 5.4.1 Patch available GHSA-cp47-r258-q626
  • vega (npm) Vendor— Affected before 4.5.1 Fixed in 4.5.1 Patch available GHSA-cp47-r258-q626

Remediation

  • Fix · GHSA-cp47-r258-q626 vega (npm) Fixed in 5.4.1 Advisory →
  • Fix · GHSA-cp47-r258-q626 vega (npm) Fixed in 4.5.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-cp47-r258-q626

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences