Read the docs
TI-2023-30699 Aliases GHSA-wxwq-525w-hcqx

Yapscan Denial of Service vulnerability in report server

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact If you use the report server, it may be vulnerable to a Denial of Service attack. ### Patches Has been patched in v0.19.2. ### References The vulnerability was inherited by the following upstream vulnerabilites - [golang.org/x/text < v0.3.7](https://github.com/advisories/GHSA-ppp9-7jff-5vj2) - [golang.org/x/net < 0.0.0-20220906165146-f3363e06e74c](https://github.com/advisories/GHSA-69cg-p879-7622)

Why it matters now

Fix Fixed github.com/fkie-cad/yapscan (Go): 0.19.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—github.com/fkie-cad/yapscan (Go)0.18.0 to before 0.19.20.19.2Patch availableGHSA-wxwq-525w-hcqx
  • github.com/fkie-cad/yapscan (Go) Vendor— Affected 0.18.0 to before 0.19.2 Fixed in 0.19.2 Patch available GHSA-wxwq-525w-hcqx

Remediation

  • Fix · GHSA-wxwq-525w-hcqx github.com/fkie-cad/yapscan (Go) Fixed in 0.19.2 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-wxwq-525w-hcqx

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences