Karate has vulnerable dependency on json-smart package (CVE-2023-1370)
Priority LOW 38CWE-674Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-674.
Summary
### Summary The CVE  ### How to fix it Very simple, just upgrade json-path package to 2.8.0 (from 2.7.0) inside karate-core pom.xml ;)
Why it matters now
Fix Fixed com.intuit.karate:karate-core (Maven): 1.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | com.intuit.karate:karate-core (Maven) | 1.3.1 to before 1.4.0 | 1.4.0 | Patch available | GHSA-5x5q-8cgm-2hjq |
- com.intuit.karate:karate-core (Maven) Vendor— Affected 1.3.1 to before 1.4.0 Fixed in 1.4.0 Patch available GHSA-5x5q-8cgm-2hjq
Remediation
- Fix · GHSA-5x5q-8cgm-2hjq com.intuit.karate:karate-core (Maven) Fixed in 1.4.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-5x5q-8cgm-2hjq
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences