Read the docs
TI-2023-30719 Aliases GHSA-48wp-p9qv-4j64

Commonmarker vulnerable to to several quadratic complexity bugs that may lead to denial of service

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

## Impact Several quadratic complexity bugs in commonmarker's underlying [`cmark-gfm`](https://github.com/github/cmark-gfm) library may lead to unbounded resource exhaustion and subsequent denial of service. The following vulnerabilities were addressed: * [CVE-2023-24824](https://github.com/github/cmark-gfm/security/advisories/GHSA-66g8-4hjf-77xh) * [CVE-2023-26485](https://github.com/github/cmark-gfm/security/advisories/GHSA-r8vr-c48j-fcc5) For more information, consult the release notes for version [`0.23.0.gfm.10`](https://github.com/github/cmark-gfm/releases/tag/0.29.0.gfm.10) and [`0.23.0.gfm.11`](https://github.com/github/cmark-gfm/releases/tag/0.29.0.gfm.11). ## Mitigation Users are advised to upgrade to commonmarker version [`0.23.9`](https://rubygems.org/gems/commonmarker/versions/0.23.9).

Why it matters now

Fix Fixed commonmarker (RubyGems): 0.23.9

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—commonmarker (RubyGems)before 0.23.90.23.9Patch availableGHSA-48wp-p9qv-4j64
  • commonmarker (RubyGems) Vendor— Affected before 0.23.9 Fixed in 0.23.9 Patch available GHSA-48wp-p9qv-4j64

Remediation

  • Fix · GHSA-48wp-p9qv-4j64 commonmarker (RubyGems) Fixed in 0.23.9 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-48wp-p9qv-4j64

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences