Read the docs
TI-2023-30750 Aliases GHSA-68jh-rf6x-836f

@apollo/server vulnerable to unsafe application of Content Security Policy via reused nonces

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Context Content Security Policies (CSP) are a defense-in-depth strategy against XSS attacks. Improper application of CSP isn't itself a vulnerability, but it does fail to prevent XSS in the event that there is a viable attack vector for an XSS attack. ### Impact There aren't any XSS attack vectors via the Apollo Server landing pages _known to Apollo_, so to our knowledge there is no impact. However, if there are existing XSS vectors that haven't been reported and patched, then all users of Apollo Server's landing pages have a vulnerability which won't be prevented by the current CSP implemented by the landing pages. Prior to version 4.7.1, there was no CSP implemented at all. However, the initial CSP implementation (4.7.1+) reused nonces. While this sufficiently resolved the issue w.r.t. scripts not running in Safari, it did not implement CSP in a safe or conventional way. ### Patches The issue is patched in the latest version of Apollo Server, v4.7.4. The changes can be reviewed in [the merge commit](https://github.com/apollographql/apollo-server/commit/0adaf80d1ee51d8c7e5fd863c04478536d15eb8c). ### Workarounds The landing page can be disabled completely until the patch can be upgraded to. https://www.apollographql.com/docs/apollo-server/api/plugin/landing-pages/#disabling-the-landing-page ### References https://content-security-policy.com/nonce/

Why it matters now

Fix Fixed @apollo/server (npm): 4.7.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@apollo/server (npm)4.7.1 to before 4.7.44.7.4Patch availableGHSA-68jh-rf6x-836f
  • @apollo/server (npm) Vendor— Affected 4.7.1 to before 4.7.4 Fixed in 4.7.4 Patch available GHSA-68jh-rf6x-836f

Remediation

  • Fix · GHSA-68jh-rf6x-836f @apollo/server (npm) Fixed in 4.7.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-68jh-rf6x-836f

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences