Cross-Site Scripting in CKEditor4 WordCount Plugin
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.
Summary
> ### CVSS: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C` (4.4) ### Problem The [WordCount](https://ckeditor.com/cke4/addon/wordcount) plugin ([`npm:ckeditor-wordcount-plugin`](https://www.npmjs.com/package/ckeditor-wordcount-plugin)) for CKEditor4 is vulnerable to cross-site scripting when switching to the source code mode. This plugin is enabled via the `Full.yaml` configuration present, but is not active in the default configuration. In default scenarios, exploiting this vulnerability requires a valid backend user account. However, if custom plugins are used on the website frontend, which accept and reflect rich-text content submitted by users, no authentication is required. ### Solution Update to TYPO3 versions 9.5.42 ELTS, 10.4.39 ELTS, 11.5.30 that fix the problem described above. ### Credits Thanks to Sybille Peters who reported this issue, and to TYPO3 core & security team member Oliver Hader who fixed the issue. ### References * [TYPO3-CORE-SA-2023-004](https://typo3.org/security/advisory/typo3-core-sa-2023-004) * https://github.com/w8tcha/CKEditor-WordCount-Plugin/security/advisories/GHSA-q9w4-w667-qqj4
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | typo3/cms-rte-ckeditor (Packagist) | 9.5.0 to before 9.5.42 | 9.5.42 | Patch available | GHSA-m8fw-p3cr-6jqc |
| — | typo3/cms-rte-ckeditor (Packagist) | 10.0.0 to before 10.4.39 | 10.4.39 | Patch available | GHSA-m8fw-p3cr-6jqc |
| — | typo3/cms-rte-ckeditor (Packagist) | 11.0.0 to before 11.5.30 | 11.5.30 | Patch available | GHSA-m8fw-p3cr-6jqc |
- typo3/cms-rte-ckeditor (Packagist) Vendor— Affected 9.5.0 to before 9.5.42 Fixed in 9.5.42 Patch available GHSA-m8fw-p3cr-6jqc
- typo3/cms-rte-ckeditor (Packagist) Vendor— Affected 10.0.0 to before 10.4.39 Fixed in 10.4.39 Patch available GHSA-m8fw-p3cr-6jqc
- typo3/cms-rte-ckeditor (Packagist) Vendor— Affected 11.0.0 to before 11.5.30 Fixed in 11.5.30 Patch available GHSA-m8fw-p3cr-6jqc
Remediation
- Fix · GHSA-m8fw-p3cr-6jqc typo3/cms-rte-ckeditor (Packagist) Fixed in 9.5.42 Advisory →
- Fix · GHSA-m8fw-p3cr-6jqc typo3/cms-rte-ckeditor (Packagist) Fixed in 10.4.39 Advisory →
- Fix · GHSA-m8fw-p3cr-6jqc typo3/cms-rte-ckeditor (Packagist) Fixed in 11.5.30 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-m8fw-p3cr-6jqc
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences