Read the docs
TI-2023-30783 Aliases GHSA-r3hf-q8q7-fv2p

Angular critical CSS inlining Cross-site Scripting Vulnerability Advisory

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

### Impact Angular Universal applications on 16.1.0 and 16.1.1 using critical CSS inlining are vulnerable to a [cross-site scripting (XSS)](https://owasp.org/www-community/attacks/xss/) attack where an attacker can trick another user into visiting a page which injects malicious JavaScript. Angular CLI applications without Universal do perform critical CSS inlining as well, however exploiting this requires a malicious actor to already have access to modify source code directly. ### Patches `@nguniversal/common` should be upgraded to 16.1.2 or higher. 16.2.0-rc.0 is safe. ### Workarounds The easiest solution is likely to upgrade Universal to 16.1.2 or downgrade to 16.0.x or lower. Alternatively you can [override](https://docs.npmjs.com/cli/v9/configuring-npm/package-json#overrides) specifically the `critters` dependency with version `0.0.20` in your `package.json`. ```json { "overrides": { "critters": "0.0.20" } } ``` ### References * [Angular Blog Post](https://blog.angular.io/notice-of-xss-issue-affecting-angular-universal-16-1-0-16-1-1-95dbae068f)

Why it matters now

Fix Fixed @nguniversal/common (npm): 16.1.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@nguniversal/common (npm)16.1.0 to before 16.1.216.1.2Patch availableGHSA-r3hf-q8q7-fv2p
  • @nguniversal/common (npm) Vendor— Affected 16.1.0 to before 16.1.2 Fixed in 16.1.2 Patch available GHSA-r3hf-q8q7-fv2p

Remediation

  • Fix · GHSA-r3hf-q8q7-fv2p @nguniversal/common (npm) Fixed in 16.1.2 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-r3hf-q8q7-fv2p

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences