Read the docs
TI-2023-30785 Aliases GHSA-f8pq-3926-8gx5

Unsanitized user controlled input in module generation

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

## Impact The `import-in-the-middle` loader used by `@opentelemetry/instrumentation` works by generating a wrapper module on the fly. The wrapper uses the module specifier to load the original module and add some wrapping code. It allows for remote code execution in cases where an application passes user-supplied input directly to an `import()` function. ## Patches This vulnerability has been patched in `@opentelemetry/instrumentation` version `0.41.2` ## Workarounds - Do not pass any user-supplied input to `import()`. Instead, verify it against a set of allowed values. - If using `@opentelemetry/instrumentation` with support for EcmaScript Modules is not needed, ensure that none of the following options are set (either via command-line or the `NODE_OPTIONS` environment variable): ``` --experimental-loader=@opentelemetry/instrumentation/hook.mjs --experimental-loader @opentelemetry/instrumentation/hook.mjs --loader=import-in-the-middle/hook.mjs --loader import-in-the-middle/hook.mjs ``` ## References - https://github.com/DataDog/import-in-the-middle/security/advisories/GHSA-5r27-rw8r-7967

Why it matters now

Fix Fixed @opentelemetry/instrumentation (npm): 0.41.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@opentelemetry/instrumentation (npm)0.40.0 to before 0.41.20.41.2Patch availableGHSA-f8pq-3926-8gx5
  • @opentelemetry/instrumentation (npm) Vendor— Affected 0.40.0 to before 0.41.2 Fixed in 0.41.2 Patch available GHSA-f8pq-3926-8gx5

Remediation

  • Fix · GHSA-f8pq-3926-8gx5 @opentelemetry/instrumentation (npm) Fixed in 0.41.2 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-f8pq-3926-8gx5

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences