Read the docs
TI-2023-30790 Aliases GHSA-jxcx-3h54-qqxx

SilverStripe CMS Cross-site Scripting vulnerabilities inherited from TinyMCE

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

TinyMCE 4.x is vulnerable to several XSS vectors, which had been patched in later versions. Two of these have been identified as affecting silverstripe/admin. Only Silverstripe CMS 4 is affected by these vulnerabilities. It's not possible to upgrade Silverstripe CMS 4 to use a more recent release of TinyMCE without introducing breaking changes. Instead, the security patches that shipped in later releases of TinyMCE have been backported to the TinyMCE version bundled in silverstripe/admin. Silverstripe CMS 5 is not affected by these vulnerabilities because it uses TinyMCE 6.

Why it matters now

Fix Fixed silverstripe/admin (Packagist): 1.13.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—silverstripe/admin (Packagist)1.0.0 to before 1.13.61.13.6Patch availableGHSA-jxcx-3h54-qqxx
  • silverstripe/admin (Packagist) Vendor— Affected 1.0.0 to before 1.13.6 Fixed in 1.13.6 Patch available GHSA-jxcx-3h54-qqxx

Remediation

  • Fix · GHSA-jxcx-3h54-qqxx silverstripe/admin (Packagist) Fixed in 1.13.6 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-jxcx-3h54-qqxx

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences