Read the docs
TI-2023-30807 Aliases GHSA-v8gr-m533-ghj9

Vulnerable OpenSSL included in cryptography wheels

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 2.5-41.0.3 are vulnerable to several security issues. More details about the vulnerabilities themselves can be found in https://www.openssl.org/news/secadv/20230908.txt. If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

Why it matters now

Fix Fixed cryptography (PyPI): 41.0.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—cryptography (PyPI)2.5 to before 41.0.441.0.4Patch availableGHSA-v8gr-m533-ghj9
  • cryptography (PyPI) Vendor— Affected 2.5 to before 41.0.4 Fixed in 41.0.4 Patch available GHSA-v8gr-m533-ghj9

Remediation

  • Fix · GHSA-v8gr-m533-ghj9 cryptography (PyPI) Fixed in 41.0.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-v8gr-m533-ghj9

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences