Wallabag user can disable 2FA unintentionally
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
## Impact wallabag was discovered to contain a Cross-Site Request Forgery (CSRF) which allows attackers to arbitrarily disable 2FA through `/config/otp/app/disable` and `/config/otp/email/disable`. This vulnerability has a CVSSv3.1 score of 4.3. **You should upgrade your instance to version 2.6.7 or higher.** ## Resolution These endpoints now require POST method. ## Credits We would like to thank @dhina016 for reporting this issue through huntr.dev. Reference: https://huntr.dev/bounties/4c446fe7-2a44-4907-b0cf-4ab77d75c487/
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | wallabag/wallabag (Packagist) | 2.0.0-alpha.1 to before 2.6.7 | 2.6.7 | Patch available | GHSA-56fm-hfp3-x3w3 |
- wallabag/wallabag (Packagist) Vendor— Affected 2.0.0-alpha.1 to before 2.6.7 Fixed in 2.6.7 Patch available GHSA-56fm-hfp3-x3w3
Remediation
- Fix · GHSA-56fm-hfp3-x3w3 wallabag/wallabag (Packagist) Fixed in 2.6.7 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-56fm-hfp3-x3w3
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences