CefSharp affected by libvpx's heap buffer overflow in vp8 encoding
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
Google is aware that an exploit for CVE-2023-5217 exists in the wild. Description Heap buffer overflow in vp8 encoding in libvpx in Google Chrome prior to 117.0.5938.132 and libvpx 1.13.1 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High) References - https://www.cve.org/CVERecord?id=CVE-2023-5217 - https://nvd.nist.gov/vuln/detail/CVE-2023-5217
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | CefSharp.Common (NuGet) | before 117.2.20 | 117.2.20 | Patch available | GHSA-4c29-gfrp-g6x9 |
| — | CefSharp.Common.NETCore (NuGet) | before 117.2.20 | 117.2.20 | Patch available | GHSA-4c29-gfrp-g6x9 |
- CefSharp.Common (NuGet) Vendor— Affected before 117.2.20 Fixed in 117.2.20 Patch available GHSA-4c29-gfrp-g6x9
- CefSharp.Common.NETCore (NuGet) Vendor— Affected before 117.2.20 Fixed in 117.2.20 Patch available GHSA-4c29-gfrp-g6x9
Remediation
- Fix · GHSA-4c29-gfrp-g6x9 CefSharp.Common (NuGet) Fixed in 117.2.20 Advisory →
- Fix · GHSA-4c29-gfrp-g6x9 CefSharp.Common.NETCore (NuGet) Fixed in 117.2.20 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-4c29-gfrp-g6x9
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences