Read the docs
TI-2023-30821 Aliases GHSA-f9pm-4g9p-6vm3

Bundled libwebp in pywebp vulnerable

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact pywebp versions before v0.3.0 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863. The vulnerability was a heap buffer overflow which allowed a remote attacker to perform an out of bounds memory write. ### Patches The problem has been patched upstream in libwebp 1.3.2. pywebp was updated to bundle a patched version of libwebp in v0.3.0. ### Workarounds No known workarounds without upgrading. ### References - https://www.rezilion.com/blog/rezilion-researchers-uncover-new-details-on-severity-of-google-chrome-zero-day-vulnerability-cve-2023-4863/ - https://nvd.nist.gov/vuln/detail/CVE-2023-4863

Why it matters now

Fix Fixed webp (PyPI): 0.3.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—webp (PyPI)before 0.3.00.3.0Patch availableGHSA-f9pm-4g9p-6vm3
  • webp (PyPI) Vendor— Affected before 0.3.0 Fixed in 0.3.0 Patch available GHSA-f9pm-4g9p-6vm3

Remediation

  • Fix · GHSA-f9pm-4g9p-6vm3 webp (PyPI) Fixed in 0.3.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-f9pm-4g9p-6vm3

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences