Read the docs
TI-2023-30826 Aliases GHSA-rc4v-99cr-pjcm

Prototype Pollution in ali-security/mongoose

Priority LOW 38CWE-1321Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact This vulnerability causes a Prototype Pollution in document.js, through functions such as findByIdAndUpdate(). For applications using Express and EJS, this can potentially allow remote code execution. ### Patches The original patched version for mongoose 5.3.3 did not include a fix for CVE-2023-3696. Therefore the existing version @seal-security/mongoose-fixed version 5.3.3 is affected by this vulnerability (though it is protected from CVE-2022-2564 and CVE-2019-17426). To mitigate this issue, a @seal-security/mongoose-fixed version 5.3.4 has been deployed. Note that this version is compatible with the original mongoose version 5.3.3, not version 5.3.4 ### References https://security.snyk.io/vuln/SNYK-JS-MONGOOSE-5777721 https://github.com/advisories/GHSA-9m93-w8w6-76hh https://github.com/Automattic/mongoose/commit/f1efabf350522257364aa5c2cb36e441cf08f1a2

Why it matters now

Fix Fixed @seal-security/mongoose-fixed (npm): 5.3.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@seal-security/mongoose-fixed (npm)5.3.3 to before 5.3.45.3.4Patch availableGHSA-rc4v-99cr-pjcm
  • @seal-security/mongoose-fixed (npm) Vendor— Affected 5.3.3 to before 5.3.4 Fixed in 5.3.4 Patch available GHSA-rc4v-99cr-pjcm

Remediation

  • Fix · GHSA-rc4v-99cr-pjcm @seal-security/mongoose-fixed (npm) Fixed in 5.3.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-rc4v-99cr-pjcm

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences