Read the docs
TI-2023-30852 Aliases GHSA-pjjw-qhg8-p2p9

aiohttp has vulnerable dependency that is vulnerable to request smuggling

Priority LOW 38CWE-444Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Summary llhttp 8.1.1 is vulnerable to two request smuggling vulnerabilities. Details have not been disclosed yet, so refer to llhttp for future information. The issue is resolved by using llhttp 9+ (which is included in aiohttp 3.8.6+).

Why it matters now

Fix Fixed aiohttp (PyPI): 3.8.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—aiohttp (PyPI)before 3.8.63.8.6Patch availableGHSA-pjjw-qhg8-p2p9
  • aiohttp (PyPI) Vendor— Affected before 3.8.6 Fixed in 3.8.6 Patch available GHSA-pjjw-qhg8-p2p9

Remediation

  • Fix · GHSA-pjjw-qhg8-p2p9 aiohttp (PyPI) Fixed in 3.8.6 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-pjjw-qhg8-p2p9

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences