Safe execution flag bypass in Frappe Server Scripts
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Frappe before 14.59.0 and 15.x before 15.5.0 contain a sandbox flaw where the frappe.flags.in_safe_exec flag can become False during Server Script execution when one server script triggers another. CWE-372 covers this incomplete internal state distinction. An authenticated high-privileged user can craft a Server Script that triggers other server scripts, such as by saving a document, so the remaining code runs without safe execution protections.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Frappe before 14.59.0 and 15.x before 15.5.0 contains a sandbox flaw where the frappe.flags.in_safe_exec global flag can become False during Server Script execution when one server script triggers another. Authenticated high-privileged users can craft a Server Script that triggers other server scripts, such as by saving a document, so the remaining code runs without safe execution protections.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Frappe to 14.59.0 or 15.5.0, the fixed versions for the 14 and 15 lines.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA frappe (frappe) Fixed in 14.59.0, 15.5.0
Timeline
- 2026-10-12 Threatist record created from CVE-2023-54406
- 2026-10-13 Alias added: GHSA-fg2g-fx2h-8fqw
- 2026-10-13 Priority changed: MEDIUM → LOW
- 2026-10-16 CISA SSVC decision points changed
References
More frappe vulnerabilities
- TI-2026-28140 ERPNext v15.103.1 and before is vulnerable to Server-Side Template Injection (SSTI). CVSS 3.1CRITICAL 9.8
- TI-2025-40873 An issue was discovered in Frappe ERPNext through 15.89.0. CVSS 3.1CRITICAL 9.8
- TI-2025-40872 An issue was discovered in Frappe ERPNext through 15.89.0. CVSS 3.1CRITICAL 9.8
- TI-2025-40871 A Server-Side Template Injection (SSTI) vulnerability exists in the Frappe ERPNext… CVSS 3.1CRITICAL 9.8
- TI-2025-32462 In Frappe ERPNext 15.57.5, the function get_rfq_containing_supplier() at… CVSS 3.1HIGH 8.2
- TI-2025-32461 In Frappe ERPNext 15.57.5, the function get_stock_balance_for() at… CVSS 3.1HIGH 8.2
Sources
- CVE-2023-54406 · CVE Program
- CVE-2023-54406 · NVD
- FIRST EPSS
- GHSA-fg2g-fx2h-8fqw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences