Incorrect authorization in Dell CPG BIOS
Priority LOW 32CWE-863Published · Updated
Key facts
- Attack vector
- Physical
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
Dell Client Platform contains an incorrect authorization vulnerability. An attacker with physical access to the system could potentially exploit this vulnerability by bypassing BIOS authorization to modify settings in the BIOS.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00249 16th percentileScored 2026-11-07
Fix Fixed CPG BIOS (Dell): 1.32.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | CPG BIOS | N/A to before 1.32.0 | 1.32.0 | Patch available | CNA |
- CPG BIOS VendorDell Affected N/A to before 1.32.0 Fixed in 1.32.0 Patch available CNA
CPE configurations NVD · 30
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:xps_17_9700_firmware:*:*:*:*:*:*:*:* | before 1.30.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:xps_17_9700:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:xps_15_9500_firmware:*:*:*:*:*:*:*:* | before 1.31.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:xps_15_9500:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:vostro_7500_firmware:*:*:*:*:*:*:*:* | before 1.28.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:vostro_7500:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:precision_5750_firmware:*:*:*:*:*:*:*:* | before 1.30.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:precision_5750:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:precision_5550_firmware:*:*:*:*:*:*:*:* | before 1.31.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:precision_5550:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:xps_17_9700_firmware:*:*:*:*:*:*:*:* Versions before 1.30.0 Vulnerable ·Dell
- cpe:2.3:h:dell:xps_17_9700:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:xps_15_9500_firmware:*:*:*:*:*:*:*:* Versions before 1.31.0 Vulnerable ·Dell
- cpe:2.3:h:dell:xps_15_9500:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:vostro_7500_firmware:*:*:*:*:*:*:*:* Versions before 1.28.0 Vulnerable ·Dell
- cpe:2.3:h:dell:vostro_7500:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:precision_5750_firmware:*:*:*:*:*:*:*:* Versions before 1.30.0 Vulnerable ·Dell
- cpe:2.3:h:dell:precision_5750:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:precision_5550_firmware:*:*:*:*:*:*:*:* Versions before 1.31.0 Vulnerable ·Dell
- cpe:2.3:h:dell:precision_5550:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Show 20 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:latitude_3520_firmware:*:*:*:*:*:*:*:* | before 1.36.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_3520:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:latitude_3510_firmware:*:*:*:*:*:*:*:* | before 1.29.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_3510:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:latitude_3420_firmware:*:*:*:*:*:*:*:* | before 1.36.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_3420:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:latitude_3410_firmware:*:*:*:*:*:*:*:* | before 1.29.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_3410:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:inspiron_7501_firmware:*:*:*:*:*:*:*:* | before 1.28.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:inspiron_7501:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:inspiron_7500_firmware:*:*:*:*:*:*:*:* | before 1.28.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:inspiron_7500:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:g7_7700_firmware:*:*:*:*:*:*:*:* | before 1.32.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:g7_7700:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:g7_7500_firmware:*:*:*:*:*:*:*:* | before 1.32.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:g7_7500:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:g5_5500_firmware:*:*:*:*:*:*:*:* | before 1.30.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:g5_5500:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:g3_3500_firmware:*:*:*:*:*:*:*:* | before 1.30.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:g3_3500:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:latitude_3520_firmware:*:*:*:*:*:*:*:* Versions before 1.36.0 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_3520:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:latitude_3510_firmware:*:*:*:*:*:*:*:* Versions before 1.29.0 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_3510:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:latitude_3420_firmware:*:*:*:*:*:*:*:* Versions before 1.36.0 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_3420:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:latitude_3410_firmware:*:*:*:*:*:*:*:* Versions before 1.29.0 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_3410:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:inspiron_7501_firmware:*:*:*:*:*:*:*:* Versions before 1.28.0 Vulnerable ·Dell
- cpe:2.3:h:dell:inspiron_7501:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:inspiron_7500_firmware:*:*:*:*:*:*:*:* Versions before 1.28.0 Vulnerable ·Dell
- cpe:2.3:h:dell:inspiron_7500:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:g7_7700_firmware:*:*:*:*:*:*:*:* Versions before 1.32.0 Vulnerable ·Dell
- cpe:2.3:h:dell:g7_7700:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:g7_7500_firmware:*:*:*:*:*:*:*:* Versions before 1.32.0 Vulnerable ·Dell
- cpe:2.3:h:dell:g7_7500:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:g5_5500_firmware:*:*:*:*:*:*:*:* Versions before 1.30.0 Vulnerable ·Dell
- cpe:2.3:h:dell:g5_5500:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:g3_3500_firmware:*:*:*:*:*:*:*:* Versions before 1.30.0 Vulnerable ·Dell
- cpe:2.3:h:dell:g3_3500:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Remediation
- Fix · CNA CPG BIOS (Dell) Fixed in 1.32.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-0160
- 2026-10-03 Alias added: GHSA-47wc-gh7x-58g7
References
More Dell G3 3500 Firmware vulnerabilities
- TI-2022-10105 Dell BIOS versions contain an Insecure Automated Optimization vulnerability. CVSS 3.1HIGH 7.9
- TI-2022-10104 Stack-based buffer overflow in Dell CPG BIOS CVSS 3.1HIGH 7.8
- TI-2023-23082 Link following in Dell Client Platform, Dell Dock Firmware CVSS 3.1HIGH 7.3
- TI-2022-10102 Improper authentication in Dell CPG BIOS CVSS 3.1HIGH 7.8
- TI-2021-04657 Stack-based buffer overflow in Dell BIOSConnect CVSS 3.1HIGH 7.5
- TI-2021-04656 Stack-based buffer overflow in Dell BIOSConnect CVSS 3.1HIGH 7.5
Sources
- CVE-2024-0160 · CVE Program
- CVE-2024-0160 · NVD
- FIRST EPSS
- GHSA-47wc-gh7x-58g7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences