Time-of-check time-of-use race condition in Dell PowerEdge Platform
Priority LOW 23CWE-367Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Dell PowerEdge Server BIOS contains an TOCTOU race condition vulnerability. A local low privileged attacker could potentially exploit this vulnerability to gain access to otherwise unauthorized resources.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00098 0th percentileScored 2026-11-07
Fix Fixed PowerEdge Platform (Dell): 1.8.3, 1.3.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | PowerEdge Platform | N/A to before 1.8.3; N/A to before 1.3.3 | 1.8.3, 1.3.3 | Patch available | CNA |
- PowerEdge Platform VendorDell Affected N/A to before 1.8.3; N/A to before 1.3.3 Fixed in 1.8.3, 1.3.3 Patch available CNA
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:poweredge_r6615_firmware:*:*:*:*:*:*:*:* | before 1.8.3 | Vulnerable | Dell |
| cpe:2.3:h:dell:poweredge_r6615:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:poweredge_r7615_firmware:*:*:*:*:*:*:*:* | before 1.8.3 | Vulnerable | Dell |
| cpe:2.3:h:dell:poweredge_r7615:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:poweredge_r6625_firmware:*:*:*:*:*:*:*:* | before 1.8.3 | Vulnerable | Dell |
| cpe:2.3:h:dell:poweredge_r6625:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:poweredge_r7625_firmware:*:*:*:*:*:*:*:* | before 1.8.3 | Vulnerable | Dell |
| cpe:2.3:h:dell:poweredge_r7625:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:poweredge_c6615_firmware:*:*:*:*:*:*:*:* | before 1.3.3 | Vulnerable | Dell |
| cpe:2.3:h:dell:poweredge_c6615:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:poweredge_r6615_firmware:*:*:*:*:*:*:*:* Versions before 1.8.3 Vulnerable ·Dell
- cpe:2.3:h:dell:poweredge_r6615:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:poweredge_r7615_firmware:*:*:*:*:*:*:*:* Versions before 1.8.3 Vulnerable ·Dell
- cpe:2.3:h:dell:poweredge_r7615:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:poweredge_r6625_firmware:*:*:*:*:*:*:*:* Versions before 1.8.3 Vulnerable ·Dell
- cpe:2.3:h:dell:poweredge_r6625:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:poweredge_r7625_firmware:*:*:*:*:*:*:*:* Versions before 1.8.3 Vulnerable ·Dell
- cpe:2.3:h:dell:poweredge_r7625:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:poweredge_c6615_firmware:*:*:*:*:*:*:*:* Versions before 1.3.3 Vulnerable ·Dell
- cpe:2.3:h:dell:poweredge_c6615:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Remediation
- Fix · CNA PowerEdge Platform (Dell) Fixed in 1.8.3, 1.3.3
Timeline
- 2026-10-02 Threatist record created from CVE-2024-0171
- 2026-10-03 Alias added: GHSA-jv7c-v8gp-mvf2
References
More Dell Poweredge C6615 Firmware vulnerabilities
- TI-2024-00150 Memory corruption in Dell PowerEdge BIOS Intel 16G CVSS 3.1HIGH 8.8
- TI-2023-15743 Missing authentication in Dell PowerEdge Platform CVSS 3.1HIGH 8.8
- TI-2024-00151 Time-of-check time-of-use race condition in Dell PowerEdge BIOS Intel 16G CVSS 3.1MEDIUM 6.3
- TI-2025-19429 Dell PowerEdge Server BIOS and Dell iDRAC9, all versions, contains an Information… CVSS 3.1MEDIUM 4.9
- TI-2024-00161 Out-of-bounds read in Dell PowerEdge Platform CVSS 3.1LOW 3.8
- TI-2024-00142 Out-of-bounds read in Dell PowerEdge Platform CVSS 3.1LOW 3.8
Sources
- CVE-2024-0171 · CVE Program
- CVE-2024-0171 · NVD
- FIRST EPSS
- GHSA-jv7c-v8gp-mvf2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences