encoded_id-rails Denial of Service Vulnerability
Priority HIGH 72CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
encoded_id-rails versions before 1.0.0.beta2 are affected by an uncontrolled resource consumption vulnerability. A remote and unauthenticated attacker might cause a denial of service condition by sending an HTTP request with an extremely long "id" parameter.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01112 66th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed encoded_id-rails: 1.0.0.beta2encoded_id-rails (RubyGems): 1.0.0.beta2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | encoded_id-rails | before 1.0.0.beta2 | 1.0.0.beta2 | Patch available | CNA |
| — | encoded_id-rails (RubyGems) | before 1.0.0.beta2 | 1.0.0.beta2 | Patch available | GHSA-3px7-jm2p-6h2c |
- encoded_id-rails Vendor— Affected before 1.0.0.beta2 Fixed in 1.0.0.beta2 Patch available CNA
- encoded_id-rails (RubyGems) Vendor— Affected before 1.0.0.beta2 Fixed in 1.0.0.beta2 Patch available GHSA-3px7-jm2p-6h2c
CPE configurations NVD · 3
Remediation
- Fix · CNA encoded_id-rails Fixed in 1.0.0.beta2
- Fix · GHSA-3px7-jm2p-6h2c encoded_id-rails (RubyGems) Fixed in 1.0.0.beta2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-0241
- 2026-10-03 Alias added: GHSA-3px7-jm2p-6h2c
References
Exploit 2
Patch 1
Sources
- CVE-2024-0241 · CVE Program
- CVE-2024-0241 · NVD
- FIRST EPSS
- GHSA-3px7-jm2p-6h2c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences