Stored XSS in Tenable Nessus
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A stored XSS vulnerability exists where an authenticated, remote attacker with administrator privileges on the Nessus application could alter Nessus proxy settings, which could lead to the execution of remote arbitrary scripts.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Nessus (Tenable) Fixed in 10.7.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Tenable Nessus 10.7.0
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2024-00895 SQL injection in Tenable NessusPriority LOW 30
Timeline
- 2026-10-02 Threatist record created from CVE-2024-0955
- 2026-10-03 Alias added: GHSA-6j46-c3h7-p829
References
More Tenable Nessus vulnerabilities
- TI-2022-00687 Infinite loop in BN_mod_sqrt() reachable when parsing certificates CVSS 3.1HIGH 7.5
- TI-2021-20962 In Expat (aka libexpat) before 2.4.3, a left shift by 29 (or more) places in the… CVSS 3.1HIGH 8.8
- TI-2021-21076 In doProlog in xmlparse.c in Expat (aka libexpat) before 2.4.3, an integer overflow exists for m_groupSize. CVSS 3.1HIGH 8.1
- TI-2021-02413 NULL pointer deref in signature_algorithms processing CVSS 3.1MEDIUM 5.9
- TI-2021-02414 CA certificate check bypass with X509_V_FLAG_X509_STRICT CVSS 3.1HIGH 7.4
- TI-2022-07855 Expat (aka libexpat) before 2.4.4 has a signed integer overflow in XML_GetBuffer, for… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-0955 · CVE Program
- CVE-2024-0955 · NVD
- FIRST EPSS
- GHSA-6j46-c3h7-p829 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences