404 Solution < 2.35.8 - Admin+ SQL Injection
Priority HIGH 67CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.
Summary
The 404 Solution WordPress plugin before 2.35.8 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users such as admins.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00756 55th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed 404 Solution (Unknown): 2.35.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | 404 Solution | before 2.35.8 | 2.35.8 | Patch available | CNA |
- 404 Solution VendorUnknown Affected before 2.35.8 Fixed in 2.35.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ajexperience:404_solution:*:*:*:*:*:wordpress:*:* | before 2.35.8 | Vulnerable | Ajexperience |
- cpe:2.3:a:ajexperience:404_solution:*:*:*:*:*:wordpress:*:* Versions before 2.35.8 Vulnerable ·Ajexperience
Remediation
- Fix · CNA 404 Solution (Unknown) Fixed in 2.35.8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1068
- 2026-10-03 Alias added: GHSA-jjxf-7hh9-8j8m
References
More Ajexperience 404 Solution vulnerabilities
- TI-2023-27753 WordPress 404 Solution Plugin <= 2.34.0 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
- TI-2024-10447 404 Solution <= 2.35.19 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-28583 WordPress 404 Solution Plugin <= 2.33.0 is vulnerable to Sensitive Data Exposure CVSS 3.1MEDIUM 5.3
Sources
- CVE-2024-1068 · CVE Program
- CVE-2024-1068 · NVD
- FIRST EPSS
- GHSA-jjxf-7hh9-8j8m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences