Read the docs
TI-2024-01024 Aliases CVE-2024-1106GHSA-5cw4-8rvf-84w3

Shariff Wrapper < 4.6.10 - Admin+ Stored XSS

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Shariff Wrapper WordPress plugin before 4.6.10 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00417 36th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Shariff Wrapper (Unknown): 4.6.10

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownShariff Wrapperbefore 4.6.104.6.10Patch availableCNA
  • Shariff Wrapper VendorUnknown Affected before 4.6.10 Fixed in 4.6.10 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:datenverwurstungszentrale:shariff_wrapper:*:*:*:*:*:wordpress:*:*before 4.6.10Vulnerable3uu
  • cpe:2.3:a:datenverwurstungszentrale:shariff_wrapper:*:*:*:*:*:wordpress:*:* Versions before 4.6.10 Vulnerable ·3uu

Remediation

  • Fix · CNA Shariff Wrapper (Unknown) Fixed in 4.6.10

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-1106
  2. 2026-10-03 Alias added: GHSA-5cw4-8rvf-84w3

References

  • TI-2024-03818 Shariff Wrapper <= 4.6.13 - Unauthenticated Local File Inclusion CVSS 3.1CRITICAL 9.8
  • TI-2024-19283 WordPress Shariff Wrapper plugin <= 4.6.10 - Contributor+ Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2024-01354 Shariff Wrapper <= 4.6.10 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
  • TI-2024-00891 Shariff Wrapper <= 4.6.9 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
  • TI-2023-05957 Shariff Wrapper <= 4.6.9 - Authenticated(Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
  • TI-2024-02510 Shariff Wrapper <= 4.6.13 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4

Sources