Improper input validation in Concrete CMS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Concrete CMS in version 9 before 9.2.5 is vulnerable to reflected XSS via the Image URL Import Feature due to insufficient validation of administrator provided data. A rogue administrator could inject malicious code when importing images, leading to the execution of the malicious code on the website user’s browser. The Concrete CMS Security team scored this 2 with CVSS v3 vector AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:N/A:N. This does not affect Concrete versions prior to version 9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Concrete CMS | Concrete CMS | 9.0.0 to before 9.2.5 | 9.2.5 | Patch available | CNA |
| — | concrete5/concrete5 (Packagist) | 9.0.0RC1 to before 9.2.5 | 9.2.5 | Patch available | GHSA-9v3w-cj7m-qh5g |
- Concrete CMS VendorConcrete CMS Affected 9.0.0 to before 9.2.5 Fixed in 9.2.5 Patch available CNA
- concrete5/concrete5 (Packagist) Vendor— Affected 9.0.0RC1 to before 9.2.5 Fixed in 9.2.5 Patch available GHSA-9v3w-cj7m-qh5g
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* | 9.0.0 to before 9.2.5 | Vulnerable | Concrete CMS |
- cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* Versions 9.0.0 to before 9.2.5 Vulnerable ·Concrete CMS
Remediation
- Fix · CNA Concrete CMS (Concrete CMS ) Fixed in 9.2.5
- Fix · GHSA-9v3w-cj7m-qh5g concrete5/concrete5 (Packagist) Fixed in 9.2.5 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Concrete CMS 9.2.5
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2024-01161 Concrete CMS version 9 before 9.2.5 vulnerable to stored XSS via the Role Name fieldPriority LOW 25
- TI-2024-01159 Improper input validation in Concrete CMSPriority LOW 22
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1246
- 2026-10-03 Alias added: GHSA-9v3w-cj7m-qh5g
References
Advisory 3
More Concrete Cms vulnerabilities
- TI-2026-23602 ConcreteCMS v9.4.7 contains a Denial of Service (DoS) vulnerability in the File Manager… CVSS 3.1MEDIUM 6.5
- TI-2023-23992 A Cross Site Scripting (XSS) vulnerability in Concrete CMS from versions 9.2.0 to 9.2.2… CVSS 3.1MEDIUM 5.4
- TI-2023-26495 Concrete CMS before 8.5.13 and 9.x before 9.2.2 allows unauthorized access because… CVSS 3.1CRITICAL 9.8
- TI-2026-14907 Missing authorization in Concrete CMS CVSS 4.0HIGH 8.7
- TI-2022-06200 Cleartext transmission of sensitive information in https://github.com/concrete5/concrete5 CVSS 3.1CRITICAL 9.8
- TI-2021-17294 An issue was discovered in Concrete CMS through 8.5.5. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-1246 · CVE Program
- CVE-2024-1246 · NVD
- FIRST EPSS
- GHSA-9v3w-cj7m-qh5g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences