Role Overwriting via Silent JIT Provisioning in Multiple WSO2 Products Enables Privilege Escalation
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The silent Just-In-Time (JIT) provisioning feature in federated authentication implementations fails to properly segregate user roles during account creation when a federated user shares a username with a local user. This allows the provisioning process to overwrite existing roles of local users with roles assigned to the federated user. Exploitation requires a federated identity provider (IDP) with silent JIT provisioning enabled and an attacker's knowledge of a local user's username. When these conditions are met, a malicious individual can leverage the JIT provisioning process to modify the roles of local users. The overwritten roles are limited to those defined within the federated IDP, typically granting minimal access rights unless explicitly configured otherwise by the federated IDP administrator.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WSO2 | WSO2 API Manager | 3.0.0 to before 3.0.0.153; 3.1.0 to before 3.1.0.267; 3.2.0 to before 3.2.0.351; 4.0.0 to before 4.0.0.269; 4.1.0 to before 4.1.0.169 | 3.0.0.153, 3.1.0.267, 3.2.0.351, 4.0.0.269, 4.1.0.169 | Patch available | CNA |
| WSO2 | WSO2 Identity Server | 5.8.0 to before 5.8.0.101; 5.9.0 to before 5.9.0.138; 5.10.0 to before 5.10.0.284; 5.11.0 to before 5.11.0.321 | 5.8.0.101, 5.9.0.138, 5.10.0.284, 5.11.0.321 | Patch available | CNA |
| WSO2 | WSO2 Identity Server as Key Manager | 5.9.0 to before 5.9.0.148; 5.10.0 to before 5.10.0.280 | 5.9.0.148, 5.10.0.280 | Patch available | CNA |
| WSO2 | WSO2 Open Banking AM | 2.0.0 to before 2.0.0.313 | 2.0.0.313 | Patch available | CNA |
| WSO2 | WSO2 Open Banking IAM | 2.0.0 to before 2.0.0.333 | 2.0.0.333 | Patch available | CNA |
- WSO2 API Manager VendorWSO2 Affected 3.0.0 to before 3.0.0.153; 3.1.0 to before 3.1.0.267; 3.2.0 to before 3.2.0.351; 4.0.0 to before 4.0.0.269; 4.1.0 to before 4.1.0.169 Fixed in 3.0.0.153, 3.1.0.267, 3.2.0.351, 4.0.0.269, 4.1.0.169 Patch available CNA
- WSO2 Identity Server VendorWSO2 Affected 5.8.0 to before 5.8.0.101; 5.9.0 to before 5.9.0.138; 5.10.0 to before 5.10.0.284; 5.11.0 to before 5.11.0.321 Fixed in 5.8.0.101, 5.9.0.138, 5.10.0.284, 5.11.0.321 Patch available CNA
- WSO2 Identity Server as Key Manager VendorWSO2 Affected 5.9.0 to before 5.9.0.148; 5.10.0 to before 5.10.0.280 Fixed in 5.9.0.148, 5.10.0.280 Patch available CNA
- WSO2 Open Banking AM VendorWSO2 Affected 2.0.0 to before 2.0.0.313 Fixed in 2.0.0.313 Patch available CNA
- WSO2 Open Banking IAM VendorWSO2 Affected 2.0.0 to before 2.0.0.333 Fixed in 2.0.0.333 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wso2:api_manager:*:*:*:*:*:*:*:* | 3.0.0 to before 3.0.0.153; 3.1.0 to before 3.1.0.267; 3.2.0 to before 3.2.0.351; 4.0.0 to before 4.0.0.269; 4.1.0 to before 4.1.0.169 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:identity_server:*:*:*:*:*:*:*:* | 5.8.0 to before 5.8.0.101; 5.9.0 to before 5.9.0.138; 5.10.0 to before 5.10.0.284; 5.11.0 to before 5.11.0.321 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:identity_server_as_key_manager:*:*:*:*:*:*:*:* | 5.9.0 to before 5.9.0.148; 5.10.0 to before 5.10.0.280 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:open_banking_am:*:*:*:*:*:*:*:* | 2.0.0 to before 2.0.0.313 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:open_banking_iam:*:*:*:*:*:*:*:* | 2.0.0 to before 2.0.0.333 | Vulnerable | WSO2 |
- cpe:2.3:a:wso2:api_manager:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.0.0.153; 3.1.0 to before 3.1.0.267; 3.2.0 to before 3.2.0.351; 4.0.0 to before 4.0.0.269; 4.1.0 to before 4.1.0.169 Vulnerable ·WSO2
- cpe:2.3:a:wso2:identity_server:*:*:*:*:*:*:*:* Versions 5.8.0 to before 5.8.0.101; 5.9.0 to before 5.9.0.138; 5.10.0 to before 5.10.0.284; 5.11.0 to before 5.11.0.321 Vulnerable ·WSO2
- cpe:2.3:a:wso2:identity_server_as_key_manager:*:*:*:*:*:*:*:* Versions 5.9.0 to before 5.9.0.148; 5.10.0 to before 5.10.0.280 Vulnerable ·WSO2
- cpe:2.3:a:wso2:open_banking_am:*:*:*:*:*:*:*:* Versions 2.0.0 to before 2.0.0.313 Vulnerable ·WSO2
- cpe:2.3:a:wso2:open_banking_iam:*:*:*:*:*:*:*:* Versions 2.0.0 to before 2.0.0.333 Vulnerable ·WSO2
Remediation
- Fix · CNA WSO2 API Manager (WSO2) Fixed in 3.0.0.153, 3.1.0.267, 3.2.0.351, 4.0.0.269, 4.1.0.169
- Fix · CNA WSO2 Identity Server (WSO2) Fixed in 5.8.0.101, 5.9.0.138, 5.10.0.284, 5.11.0.321
- Fix · CNA WSO2 Identity Server as Key Manager (WSO2) Fixed in 5.9.0.148, 5.10.0.280
- Fix · CNA WSO2 Open Banking AM (WSO2) Fixed in 2.0.0.313
- Fix · CNA WSO2 Open Banking IAM (WSO2) Fixed in 2.0.0.333
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1248
- 2026-10-03 Alias added: GHSA-c9ww-fm69-95fg
References
More WSO2 Api Manager vulnerabilities
- TI-2026-04755 Authentication Bypass via JWT Algorithm Mismatch in Multiple WSO2 Products Allows Account Takeover KEVCVSS 3.1CRITICAL 10.0
- TI-2022-11928 Certain WSO2 products allow unrestricted file upload with resultant remote code execution. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-15069 The Management Console in WSO2 API Manager through 3.1.0 and API Microgateway 2.2.0… CVSS 3.1CRITICAL 9.1
- TI-2023-15163 A reflected cross-site scripting (XSS) vulnerability in /authenticationendpoint/login.do… CVSS 3.1MEDIUM 6.1
- TI-2022-12002 A reflected XSS issue exists in the Management Console of several WSO2 products. CVSS 3.1MEDIUM 6.1
- TI-2025-13722 Account Takeover via Conditional Authentication Script Logic in Multiple WSO2 Products CVSS 3.1CRITICAL 9.4
Sources
- CVE-2024-1248 · CVE Program
- CVE-2024-1248 · NVD
- FIRST EPSS
- GHSA-c9ww-fm69-95fg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences