My Calendar < 3.4.24 - Authenticated Stored XSS
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The My Calendar WordPress plugin before 3.4.24 does not sanitise and escape some parameters, which could allow users with a role as low as Subscriber to perform Cross-Site Scripting attacks (depending on the permissions set by the admin)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00425 36th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed My Calendar (Unknown): 3.4.24
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | My Calendar | before 3.4.24 | 3.4.24 | Patch available | CNA |
- My Calendar VendorUnknown Affected before 3.4.24 Fixed in 3.4.24 Patch available CNA
Remediation
- Fix · CNA My Calendar (Unknown) Fixed in 3.4.24
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1274
- 2026-10-03 Alias added: GHSA-9576-cchc-4f79
References
More joedolson My Calendar vulnerabilities
- TI-2023-05838 SQL injection in my-calendar CVSS 3.1CRITICAL 9.8
- TI-2012-05245 Cross-site scripting (XSS) vulnerability in the My Calendar plugin before 1.10.2 for… CVSS 2.0LOW 2.6
Sources
- CVE-2024-1274 · CVE Program
- CVE-2024-1274 · NVD
- FIRST EPSS
- GHSA-9576-cchc-4f79 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences