Nomad Vulnerable to Arbitrary Write Through Symlink Attack
Priority LOW 35CWE-59Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
HashiCorp Nomad and Nomad Enterprise 1.5.13 up to 1.6.6, and 1.7.3 template renderer is vulnerable to arbitrary file write on the host as the Nomad client user through symlink attacks. This vulnerability, CVE-2024-1329, is fixed in Nomad 1.7.4, 1.6.7, and 1.5.14.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00617 49th percentileScored 2026-11-07
Fix Fixed github.com/hashicorp/nomad (Go): 1.5.14, 1.6.7, 1.7.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HashiCorp | Nomad | up to 1.5.13; up to 1.6.6; up to 1.7.3 | — | No fix listed | CNA |
| HashiCorp | Nomad Enterprise | up to 1.5.13; up to 1.6.6; up to 1.7.3 | — | No fix listed | CNA |
| — | github.com/hashicorp/nomad (Go) | 1.5.13 to before 1.5.14 | 1.5.14 | Patch available | GHSA-c866-8gpw-p3mv |
| — | github.com/hashicorp/nomad (Go) | 1.6.0 to before 1.6.7 | 1.6.7 | Patch available | GHSA-c866-8gpw-p3mv |
| — | github.com/hashicorp/nomad (Go) | 1.7.3 to before 1.7.4 | 1.7.4 | Patch available | GHSA-c866-8gpw-p3mv |
- Nomad VendorHashiCorp Affected up to 1.5.13; up to 1.6.6; up to 1.7.3 Fixed in — No fix listed CNA
- Nomad Enterprise VendorHashiCorp Affected up to 1.5.13; up to 1.6.6; up to 1.7.3 Fixed in — No fix listed CNA
- github.com/hashicorp/nomad (Go) Vendor— Affected 1.5.13 to before 1.5.14 Fixed in 1.5.14 Patch available GHSA-c866-8gpw-p3mv
- github.com/hashicorp/nomad (Go) Vendor— Affected 1.6.0 to before 1.6.7 Fixed in 1.6.7 Patch available GHSA-c866-8gpw-p3mv
- github.com/hashicorp/nomad (Go) Vendor— Affected 1.7.3 to before 1.7.4 Fixed in 1.7.4 Patch available GHSA-c866-8gpw-p3mv
CPE configurations NVD · 2
Remediation
- Fix · GHSA-c866-8gpw-p3mv github.com/hashicorp/nomad (Go) Fixed in 1.5.14 Advisory →
- Fix · GHSA-c866-8gpw-p3mv github.com/hashicorp/nomad (Go) Fixed in 1.6.7 Advisory →
- Fix · GHSA-c866-8gpw-p3mv github.com/hashicorp/nomad (Go) Fixed in 1.7.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1329
- 2026-10-03 Alias added: GHSA-c866-8gpw-p3mv
References
Advisory 2
Other 5
- https://github.com/hashicorp/nomad/issues/19888
- https://github.com/hashicorp/nomad/commit/b3209cbc6921e703b0e9984ce70c10b378665834
- https://github.com/hashicorp/nomad/commit/d1721c7a6fc1833778086603f818a822a34f445a
- https://github.com/hashicorp/nomad/commit/de55da677a21ac7572c0f4a8cd9abd5473c47a70
- https://github.com/hashicorp/nomad
More HashiCorp Nomad vulnerabilities
- TI-2019-09419 HashiCorp Nomad 0.9.0 through 0.9.1 has Incorrect Access Control via the exec driver. CVSS 3.0CRITICAL 9.8
- TI-2022-12559 HashiCorp Nomad and Nomad Enterprise version 0.2.0 up to 1.3.0 were impacted by go-getter… CVSS 3.1CRITICAL 9.8
- TI-2023-01674 Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation CVSS 3.1CRITICAL 10.0
- TI-2020-06436 HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region… CVSS 3.1CRITICAL 9.8
- TI-2020-16532 HashiCorp Nomad and Nomad Enterprise version 0.9.0 up to 0.12.5 client file sandbox… CVSS 3.1CRITICAL 9.1
- TI-2021-19357 HashiCorp Nomad and Nomad Enterprise up to 1.0.13, 1.1.7, and 1.2.0, with the QEMU task… CVSS 3.1HIGH 8.8
Sources
- CVE-2024-1329 · CVE Program
- CVE-2024-1329 · NVD
- FIRST EPSS
- GHSA-c866-8gpw-p3mv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences