Brocade ASCG 3.2.0 web interface does not enforce HSTS, as defined by RFC 6797 for ports 8030 and 8100
Priority LOW 35CWE-523Published · Updated
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Brocade ASCG before 3.2.0 Web Interface is not enforcing HSTS, as defined by RFC 6797. HSTS is an optional response header that can be configured on the server to instruct the browser to only communicate via HTTPS. The lack of HSTS allows downgrade attacks, SSL-stripping man-in-the-middle attacks, and weakens cookie-hijacking protections.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00369 30th percentileScored 2026-11-07
Fix Fixed ASCG (Brocade): 3.2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA ASCG (Brocade) Fixed in 3.2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1509
- 2026-10-03 Alias added: GHSA-j6jw-hg33-x575
References
More Brocade vulnerabilities
- TI-2025-01721 Code injection exposure in Fabric OS 9.1.0 through 9.1.1d6 KEVCVSS 4.0HIGH 8.6
- TI-2016-06760 Path traversal in Brocade Network Advisor versions released prior to and including 14.0.2 CVSS 3.0CRITICAL 9.8
- TI-2024-19729 hard-coded credentials in the documentation that appear as the appliance root password CVSS 3.1CRITICAL 9.8
- TI-2016-06762 Path traversal in Brocade Network Advisor versions released prior to and including 14.0.2 CVSS 3.0HIGH 7.5
- TI-2018-04739 OS command injection in Brocade Network Advisor CVSS 3.0CRITICAL 9.8
- TI-2016-06761 Path traversal in Brocade Network Advisor versions released prior to and including 14.0.2 CVSS 3.0HIGH 7.5
Sources
- CVE-2024-1509 · CVE Program
- CVE-2024-1509 · NVD
- FIRST EPSS
- GHSA-j6jw-hg33-x575 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences