Read the docs
TI-2024-01718 Aliases CVE-2024-1846GHSA-h9pr-qr4v-f87f

Responsive Tabs < 4.0.7 - Contributor+ Stored XSS

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Responsive Tabs WordPress plugin before 4.0.7 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00501 43rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Responsive Tabs (Unknown): 4.0.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownResponsive Tabsbefore 4.0.74.0.7Patch availableCNA
  • Responsive Tabs VendorUnknown Affected before 4.0.7 Fixed in 4.0.7 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpdarko:responsive_tabs:*:*:*:*:*:wordpress:*:*before 4.0.7VulnerableWP Darko
  • cpe:2.3:a:wpdarko:responsive_tabs:*:*:*:*:*:wordpress:*:* Versions before 4.0.7 Vulnerable ·WP Darko

Remediation

  • Fix · CNA Responsive Tabs (Unknown) Fixed in 4.0.7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-1846
  2. 2026-10-03 Alias added: GHSA-h9pr-qr4v-f87f

References

  • TI-2024-03816 Responsive Tabs <= 4.0.8 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.9
  • TI-2021-14981 WordPress Responsive Tabs plugin <= 4.0.5 - Cross-Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 4.8

Sources