WP-Members Membership Plugin <= 3.4.9.2 - Unauthenticated Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The WP-Members Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the X-Forwarded-For header in all versions up to, and including, 3.4.9.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page which is the edit users page. This vulnerability was partially patched in version 3.4.9.2, and was fully patched in 3.4.9.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1852
- 2026-10-03 Alias added: GHSA-j583-rf4p-48jc
References
Other 3
- https://plugins.trac.wordpress.org/browser/wp-members/trunk/includes/vendor/rocketgeek-utilities/includes/utilities.php#L168
- https://plugins.trac.wordpress.org/browser/wp-members/trunk/includes/class-wp-members-user.php#L524
- https://plugins.trac.wordpress.org/browser/wp-members/trunk/includes/class-wp-members-user-profile.php#L566
More cbutlerjr Wp-members vulnerabilities
- TI-2019-11755 The wp-members plugin before 3.2.8 for WordPress has CSRF. CVSS 3.0HIGH 8.8
- TI-2017-01512 Cross-site scripting in Chad Butler WP-Members CVSS 3.0MEDIUM 6.1
- TI-2024-09607 WP-Members <= 3.4.9.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via wpmem_loginout Shortcode CVSS 3.1MEDIUM 6.4
- TI-2023-06154 WP-Members Membership Plugin <= 3.4.8 - Missing Authorization to Sensitive Information Exposure CVSS 3.1MEDIUM 6.5
- TI-2024-08567 WP-Members Membership Plugin <= 3.4.9.5 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-01849 WP-Members Membership Plugin <= 3.4.9.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
Sources
- CVE-2024-1852 · CVE Program
- CVE-2024-1852 · NVD
- FIRST EPSS
- GHSA-j583-rf4p-48jc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences