Categorify <= 1.0.7.4 - Cross-Site Request Forgery via categorifyAjaxRenameCategory
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The Categorify plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.7.4. This is due to missing or incorrect nonce validation on the categorifyAjaxRenameCategory function. This makes it possible for unauthenticated attackers to rename categories via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1909
- 2026-10-03 Alias added: GHSA-h43f-4wgw-vfx3
References
More frenify Categorify vulnerabilities
- TI-2024-00351 Categorify <= 1.0.7.4 - Missing Authorization in categorifyAjaxAddCategory CVSS 3.1MEDIUM 4.3
- TI-2024-01536 Categorify <= 1.0.7.4 - Missing Authorization in categorifyAjaxUpdateFolderPosition CVSS 3.1MEDIUM 4.3
- TI-2024-01535 Categorify <= 1.0.7.4 - Missing Authorization in categorifyAjaxClearCategory CVSS 3.1MEDIUM 4.3
- TI-2024-01533 Categorify <= 1.0.7.4 - Missing Authorization in categorifyAjaxRenameCategory CVSS 3.1MEDIUM 4.3
- TI-2024-01532 Categorify <= 1.0.7.4 - Missing Authorization in categorifyAjaxDeleteCategory CVSS 3.1MEDIUM 4.3
- TI-2024-01779 Categorify <= 1.0.7.4 - Cross-Site Request Forgery via categorifyAjaxUpdateFolderPosition CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-1909 · CVE Program
- CVE-2024-1909 · NVD
- FIRST EPSS
- GHSA-h43f-4wgw-vfx3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences