WPB Show Core < 2.7 - Reflected XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The WPB Show Core WordPress plugin before 2.7 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin or unauthenticated users
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | wpb-show-core | before 2.7 | 2.7 | Patch available | CNA |
- wpb-show-core VendorUnknown Affected before 2.7 Fixed in 2.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpb_show_core_project:wpb_show_core:*:*:*:*:*:wordpress:*:* | before 2.7 | Vulnerable | Wpb Show Core Project |
- cpe:2.3:a:wpb_show_core_project:wpb_show_core:*:*:*:*:*:wordpress:*:* Versions before 2.7 Vulnerable ·Wpb Show Core Project
Remediation
- Fix · CNA wpb-show-core (Unknown) Fixed in 2.7
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
wpb-show-core 2.7
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2024-01202 WPB Show Core < 2.6 - Reflected XSSPriority MEDIUM 55
- TI-2024-01822 WPB Show Core < 2.7 - Reflected XSSPriority LOW 28
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1958
- 2026-10-03 Alias added: GHSA-w7x4-hw9x-fprc
References
More Wpb Show Core Project Wpb Show Core vulnerabilities
- TI-2023-05505 WPB Show Core <= 2.2 - Unauthenticated Server Side Request Forgery CVSS 3.1CRITICAL 9.8
- TI-2022-03216 WPB Show Core - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-04533 WPB Show Core <= 2.2 - Unauthenticated Local File Inclusion CVSS 3.1CRITICAL 9.8
- TI-2024-01202 WPB Show Core < 2.6 - Reflected XSS CVSS 3.1MEDIUM 4.7
- TI-2024-01822 WPB Show Core < 2.7 - Reflected XSS CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-1958 · CVE Program
- CVE-2024-1958 · NVD
- FIRST EPSS
- GHSA-w7x4-hw9x-fprc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences