Improper Restriction of Rendered UI Layers or Frames in GitLab
Priority LOW 33CWE-1021Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-1021.
Summary
A Cross Window Forgery vulnerability exists within GitLab CE/EE affecting all versions from 16.3 prior to 16.11.5, 17.0 prior to 17.0.3, and 17.1 prior to 17.1.1. This condition allows for an attacker to abuse the OAuth authentication flow via a crafted payload.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00651 51st percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD and the CNA
Fix Fixed GitLab (GitLab): 16.11.5, 17.0.3, 17.1.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 16.3 to before 16.11.5; 17.0 to before 17.0.3; 17.1 to before 17.1.1 | 16.11.5, 17.0.3, 17.1.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 16.3 to before 16.11.5; 17.0 to before 17.0.3; 17.1 to before 17.1.1 Fixed in 16.11.5, 17.0.3, 17.1.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.3.0 to before 16.11.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.3.0 to before 16.11.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 17.0.0 to before 17.0.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 17.0.0 to before 17.0.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.1.0:*:*:*:community:*:*:* | 17.1.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.1.0:*:*:*:enterprise:*:*:* | 17.1.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.3.0 to before 16.11.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.3.0 to before 16.11.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 17.0.0 to before 17.0.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 17.0.0 to before 17.0.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.1.0:*:*:*:community:*:*:* Versions 17.1.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.1.0:*:*:*:enterprise:*:*:* Versions 17.1.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 16.11.5, 17.0.3, 17.1.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2177
- 2026-10-03 Alias added: GHSA-rgx6-gx96-7frc
- 2026-10-14 EPSS moved to the 50th–90th percentile
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-2177 · CVE Program
- CVE-2024-2177 · NVD
- FIRST EPSS
- GHSA-rgx6-gx96-7frc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences