Cross-site scripting in Concrete CMS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Concrete CMS version 9 before 9.2.7 is vulnerable to Stored XSS via the Name field of a Group type since there is insufficient validation of administrator provided data for that field. A rogue administrator could inject malicious code into the Name field which might be executed when users visit the affected page. The Concrete CMS security team gave this vulnerability a CVSS v3.1 score of 2.2 with a vector of AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N Concrete versions below 9 do not include group types so they are not affected by this vulnerability. Thanks Luca Fuda for reporting.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Concrete CMS | Concrete CMS | 9.0.0 to before 9.2.7 | 9.2.7 | Patch available | CNA |
| — | concrete5/concrete5 (Packagist) | before 9.2.7 | 9.2.7 | Patch available | GHSA-4m7h-34xm-4wjv |
- Concrete CMS VendorConcrete CMS Affected 9.0.0 to before 9.2.7 Fixed in 9.2.7 Patch available CNA
- concrete5/concrete5 (Packagist) Vendor— Affected before 9.2.7 Fixed in 9.2.7 Patch available GHSA-4m7h-34xm-4wjv
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* | 9.0.0 to before 9.2.7 | Vulnerable | Concrete CMS |
- cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* Versions 9.0.0 to before 9.2.7 Vulnerable ·Concrete CMS
Remediation
- Fix · CNA Concrete CMS (Concrete CMS) Fixed in 9.2.7
- Fix · GHSA-4m7h-34xm-4wjv concrete5/concrete5 (Packagist) Fixed in 9.2.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2179
- 2026-10-03 Alias added: GHSA-4m7h-34xm-4wjv
References
More Concrete Cms vulnerabilities
- TI-2026-23602 ConcreteCMS v9.4.7 contains a Denial of Service (DoS) vulnerability in the File Manager… CVSS 3.1MEDIUM 6.5
- TI-2023-23992 A Cross Site Scripting (XSS) vulnerability in Concrete CMS from versions 9.2.0 to 9.2.2… CVSS 3.1MEDIUM 5.4
- TI-2023-26495 Concrete CMS before 8.5.13 and 9.x before 9.2.2 allows unauthorized access because… CVSS 3.1CRITICAL 9.8
- TI-2026-14907 Missing authorization in Concrete CMS CVSS 4.0HIGH 8.7
- TI-2022-06200 Cleartext transmission of sensitive information in https://github.com/concrete5/concrete5 CVSS 3.1CRITICAL 9.8
- TI-2021-17294 An issue was discovered in Concrete CMS through 8.5.5. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-2179 · CVE Program
- CVE-2024-2179 · NVD
- FIRST EPSS
- GHSA-4m7h-34xm-4wjv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences