Social Icons Widget & Block < 4.2.18 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Social Icons Widget & Block by WPZOOM WordPress plugin before 4.2.18 does not sanitise and escape some of its Widget settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Social Icons Widget & Block by WPZOOM | before 4.2.18 | 4.2.18 | Patch available | CNA |
- Social Icons Widget & Block by WPZOOM VendorUnknown Affected before 4.2.18 Fixed in 4.2.18 Patch available CNA
Remediation
- Fix · CNA Social Icons Widget & Block by WPZOOM (Unknown) Fixed in 4.2.18
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2189
- 2026-10-03 Alias added: GHSA-8962-3h36-6xxf
References
More wpzoom Social Icons Widget vulnerabilities
- TI-2024-20190 WordPress Social Icons Widget & Block by WPZOOM plugin <= 4.2.15 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2024-2189 · CVE Program
- CVE-2024-2189 · NVD
- FIRST EPSS
- GHSA-8962-3h36-6xxf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences