Incorrect Authorization in Multiple WSO2 Products Allows API Access via Refresh Token
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
An incorrect authorization vulnerability exists in multiple WSO2 products, allowing protected APIs to be accessed directly using a refresh token instead of the expected access token. Due to improper authorization checks and token mapping, session cookies are not required for API access, potentially enabling unauthorized operations. Exploitation requires an attacker to obtain a valid refresh token of an admin user. Since refresh tokens generally have a longer expiration time, this could lead to prolonged unauthorized access to API resources, impacting data confidentiality and integrity.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WSO2 | WSO2 API Manager | 4.0.0 to before 4.0.0.275; 4.1.0 to before 4.1.0.153; 4.2.0 to before 4.2.0.83 | 4.0.0.275, 4.1.0.153, 4.2.0.83 | Patch available | CNA |
| WSO2 | WSO2 Identity Server | 5.11.0 to before 5.11.0.326; 6.0.0 to before 6.0.0.172; 6.1.0 to before 6.1.0.130 | 5.11.0.326, 6.0.0.172, 6.1.0.130 | Patch available | CNA |
| — | org.wso2.am:am-parent (Maven) | 4.2.0-beta – 4.2.0 | — | No fix listed | GHSA-6qjp-wm6g-m32r |
| — | org.wso2.am:am-parent (Maven) | 4.1.0-alpha – 4.1.0 | — | No fix listed | GHSA-6qjp-wm6g-m32r |
| — | org.wso2.am:am-parent (Maven) | 4.0.0-beta – 4.0.0 | — | No fix listed | GHSA-6qjp-wm6g-m32r |
| — | org.wso2.is:identity-server-parent (Maven) | 6.1.0-beta – 6.1.0 | — | No fix listed | GHSA-6qjp-wm6g-m32r |
| — | org.wso2.is:identity-server-parent (Maven) | 6.0.0-alpha3 – 6.0.0 | — | No fix listed | GHSA-6qjp-wm6g-m32r |
| — | org.wso2.is:identity-server-parent (Maven) | 5.11.0-alpha – 5.11.0 | — | No fix listed | GHSA-6qjp-wm6g-m32r |
- WSO2 API Manager VendorWSO2 Affected 4.0.0 to before 4.0.0.275; 4.1.0 to before 4.1.0.153; 4.2.0 to before 4.2.0.83 Fixed in 4.0.0.275, 4.1.0.153, 4.2.0.83 Patch available CNA
- WSO2 Identity Server VendorWSO2 Affected 5.11.0 to before 5.11.0.326; 6.0.0 to before 6.0.0.172; 6.1.0 to before 6.1.0.130 Fixed in 5.11.0.326, 6.0.0.172, 6.1.0.130 Patch available CNA
- org.wso2.am:am-parent (Maven) Vendor— Affected 4.2.0-beta – 4.2.0 Fixed in — No fix listed GHSA-6qjp-wm6g-m32r
- org.wso2.am:am-parent (Maven) Vendor— Affected 4.1.0-alpha – 4.1.0 Fixed in — No fix listed GHSA-6qjp-wm6g-m32r
- org.wso2.am:am-parent (Maven) Vendor— Affected 4.0.0-beta – 4.0.0 Fixed in — No fix listed GHSA-6qjp-wm6g-m32r
- org.wso2.is:identity-server-parent (Maven) Vendor— Affected 6.1.0-beta – 6.1.0 Fixed in — No fix listed GHSA-6qjp-wm6g-m32r
- org.wso2.is:identity-server-parent (Maven) Vendor— Affected 6.0.0-alpha3 – 6.0.0 Fixed in — No fix listed GHSA-6qjp-wm6g-m32r
- org.wso2.is:identity-server-parent (Maven) Vendor— Affected 5.11.0-alpha – 5.11.0 Fixed in — No fix listed GHSA-6qjp-wm6g-m32r
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wso2:api_manager:4.0.0:*:*:*:*:*:*:* | 4.0.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.1.0:-:*:*:*:*:*:* | 4.1.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.2.0:-:*:*:*:*:*:* | 4.2.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:identity_server:5.11.0:*:*:*:*:*:*:* | 5.11.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:identity_server:6.0.0:*:*:*:*:*:*:* | 6.0.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:identity_server:6.1.0:*:*:*:*:*:*:* | 6.1.0 | Vulnerable | WSO2 |
- cpe:2.3:a:wso2:api_manager:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.1.0:-:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.2.0:-:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:identity_server:5.11.0:*:*:*:*:*:*:* Versions 5.11.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:identity_server:6.0.0:*:*:*:*:*:*:* Versions 6.0.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:identity_server:6.1.0:*:*:*:*:*:*:* Versions 6.1.0 Vulnerable ·WSO2
Remediation
- Fix · CNA WSO2 API Manager (WSO2) Fixed in 4.0.0.275, 4.1.0.153, 4.2.0.83
- Fix · CNA WSO2 Identity Server (WSO2) Fixed in 5.11.0.326, 6.0.0.172, 6.1.0.130
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2321
- 2026-10-03 Alias added: GHSA-6qjp-wm6g-m32r
References
Advisory 2
More WSO2 Api Manager vulnerabilities
- TI-2026-04755 Authentication Bypass via JWT Algorithm Mismatch in Multiple WSO2 Products Allows Account Takeover KEVCVSS 3.1CRITICAL 10.0
- TI-2022-11928 Certain WSO2 products allow unrestricted file upload with resultant remote code execution. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-15069 The Management Console in WSO2 API Manager through 3.1.0 and API Microgateway 2.2.0… CVSS 3.1CRITICAL 9.1
- TI-2023-15163 A reflected cross-site scripting (XSS) vulnerability in /authenticationendpoint/login.do… CVSS 3.1MEDIUM 6.1
- TI-2022-12002 A reflected XSS issue exists in the Management Console of several WSO2 products. CVSS 3.1MEDIUM 6.1
- TI-2025-13722 Account Takeover via Conditional Authentication Script Logic in Multiple WSO2 Products CVSS 3.1CRITICAL 9.4
Sources
- CVE-2024-2321 · CVE Program
- CVE-2024-2321 · NVD
- FIRST EPSS
- GHSA-6qjp-wm6g-m32r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences