Read the docs
TI-2024-02205 Aliases CVE-2024-2374GHSA-98jv-r7r8-3rqm

XML External Entity Injection in Multiple WSO2 Products Allows Arbitrary file read and Denial of Service

Priority MEDIUM 45CWE-611Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

The XML parsers within multiple WSO2 products accept user-supplied XML data without properly configuring to prevent the resolution of external entities. This omission allows malicious actors to craft XML payloads that exploit the parser's behavior, leading to the inclusion of external resources. By leveraging this vulnerability, an attacker can read confidential files from the file system and access limited HTTP resources reachable by the product. Additionally, the vulnerability can be exploited to perform denial of service attacks by exhausting server resources through recursive entity expansion or fetching large external resources.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00377 31st percentileScored 2026-11-07
Fix Fixed WSO2 API Manager (WSO2): 3.1.0.278, 3.2.0.368, 4.0.0.280 +3WSO2 Identity Server (WSO2): 5.10.0.300, 5.11.0.329, 6.0.0.179 +1+3 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
WSO2WSO2 API Manager3.1.0 to before 3.1.0.278; 3.2.0 to before 3.2.0.368; 4.0.0 to before 4.0.0.280; 4.1.0 to before 4.1.0.206; 4.2.0 to before 4.2.0.144; 4.3.0 to before 4.3.0.573.1.0.278, 3.2.0.368, 4.0.0.280, 4.1.0.206, 4.2.0.144, 4.3.0.57Patch availableCNA
WSO2WSO2 Identity Server5.10.0 to before 5.10.0.300; 5.11.0 to before 5.11.0.329; 6.0.0 to before 6.0.0.179; 6.1.0 to before 6.1.0.1365.10.0.300, 5.11.0.329, 6.0.0.179, 6.1.0.136Patch availableCNA
WSO2WSO2 Open Banking AM2.0.0 to before 2.0.0.3282.0.0.328Patch availableCNA
WSO2WSO2 Open Banking IAM2.0.0 to before 2.0.0.3482.0.0.348Patch availableCNA
WSO2WSO2 Identity Server as Key Manager5.10.0 to before 5.10.0.2965.10.0.296Patch availableCNA
  • WSO2 API Manager VendorWSO2 Affected 3.1.0 to before 3.1.0.278; 3.2.0 to before 3.2.0.368; 4.0.0 to before 4.0.0.280; 4.1.0 to before 4.1.0.206; 4.2.0 to before 4.2.0.144; 4.3.0 to before 4.3.0.57 Fixed in 3.1.0.278, 3.2.0.368, 4.0.0.280, 4.1.0.206, 4.2.0.144, 4.3.0.57 Patch available CNA
  • WSO2 Identity Server VendorWSO2 Affected 5.10.0 to before 5.10.0.300; 5.11.0 to before 5.11.0.329; 6.0.0 to before 6.0.0.179; 6.1.0 to before 6.1.0.136 Fixed in 5.10.0.300, 5.11.0.329, 6.0.0.179, 6.1.0.136 Patch available CNA
  • WSO2 Open Banking AM VendorWSO2 Affected 2.0.0 to before 2.0.0.328 Fixed in 2.0.0.328 Patch available CNA
  • WSO2 Open Banking IAM VendorWSO2 Affected 2.0.0 to before 2.0.0.348 Fixed in 2.0.0.348 Patch available CNA
  • WSO2 Identity Server as Key Manager VendorWSO2 Affected 5.10.0 to before 5.10.0.296 Fixed in 5.10.0.296 Patch available CNA

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:wso2:api_manager:*:*:*:*:*:*:*:*3.1.0 to before 3.1.0.278; 3.2.0 to before 3.2.0.368; 4.0.0 to before 4.0.0.280; 4.1.0 to before 4.1.0.206; 4.2.0 to before 4.2.0.144; 4.3.0 to before 4.3.0.57VulnerableWSO2
cpe:2.3:a:wso2:identity_server:*:*:*:*:*:*:*:*5.10.0 to before 5.10.0.300; 5.11.0 to before 5.11.0.329; 6.0.0 to before 6.0.0.179; 6.1.0 to before 6.1.0.136VulnerableWSO2
cpe:2.3:a:wso2:identity_server_as_key_manager:*:*:*:*:*:*:*:*5.10.0 to before 5.10.0.296VulnerableWSO2
cpe:2.3:a:wso2:open_banking_am:*:*:*:*:*:*:*:*2.0.0 to before 2.0.0.328VulnerableWSO2
cpe:2.3:a:wso2:open_banking_iam:*:*:*:*:*:*:*:*2.0.0 to before 2.0.0.348VulnerableWSO2
  • cpe:2.3:a:wso2:api_manager:*:*:*:*:*:*:*:* Versions 3.1.0 to before 3.1.0.278; 3.2.0 to before 3.2.0.368; 4.0.0 to before 4.0.0.280; 4.1.0 to before 4.1.0.206; 4.2.0 to before 4.2.0.144; 4.3.0 to before 4.3.0.57 Vulnerable ·WSO2
  • cpe:2.3:a:wso2:identity_server:*:*:*:*:*:*:*:* Versions 5.10.0 to before 5.10.0.300; 5.11.0 to before 5.11.0.329; 6.0.0 to before 6.0.0.179; 6.1.0 to before 6.1.0.136 Vulnerable ·WSO2
  • cpe:2.3:a:wso2:identity_server_as_key_manager:*:*:*:*:*:*:*:* Versions 5.10.0 to before 5.10.0.296 Vulnerable ·WSO2
  • cpe:2.3:a:wso2:open_banking_am:*:*:*:*:*:*:*:* Versions 2.0.0 to before 2.0.0.328 Vulnerable ·WSO2
  • cpe:2.3:a:wso2:open_banking_iam:*:*:*:*:*:*:*:* Versions 2.0.0 to before 2.0.0.348 Vulnerable ·WSO2

Remediation

  • Fix · CNA WSO2 API Manager (WSO2) Fixed in 3.1.0.278, 3.2.0.368, 4.0.0.280, 4.1.0.206, 4.2.0.144, 4.3.0.57
  • Fix · CNA WSO2 Identity Server (WSO2) Fixed in 5.10.0.300, 5.11.0.329, 6.0.0.179, 6.1.0.136
  • Fix · CNA WSO2 Open Banking AM (WSO2) Fixed in 2.0.0.328
  • Fix · CNA WSO2 Open Banking IAM (WSO2) Fixed in 2.0.0.348
  • Fix · CNA WSO2 Identity Server as Key Manager (WSO2) Fixed in 5.10.0.296

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-2374
  2. 2026-10-03 Alias added: GHSA-98jv-r7r8-3rqm

References

  • TI-2026-04755 Authentication Bypass via JWT Algorithm Mismatch in Multiple WSO2 Products Allows Account Takeover KEVCVSS 3.1CRITICAL 10.0
  • TI-2022-11928 Certain WSO2 products allow unrestricted file upload with resultant remote code execution. KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-15069 The Management Console in WSO2 API Manager through 3.1.0 and API Microgateway 2.2.0… CVSS 3.1CRITICAL 9.1
  • TI-2023-15163 A reflected cross-site scripting (XSS) vulnerability in /authenticationendpoint/login.do… CVSS 3.1MEDIUM 6.1
  • TI-2022-12002 A reflected XSS issue exists in the Management Console of several WSO2 products. CVSS 3.1MEDIUM 6.1
  • TI-2025-13722 Account Takeover via Conditional Authentication Script Logic in Multiple WSO2 Products CVSS 3.1CRITICAL 9.4
See all 94 →

Sources