Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
An issue has been discovered in GitLab affecting all versions of GitLab CE/EE 16.9 prior to 16.9.6, 16.10 prior to 16.10.4, and 16.11 prior to 16.11.1 where path traversal could lead to DoS and restricted file read.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 16.9 to before 16.9.6; 16.10 to before 16.10.4; 16.11 to before 16.11.1 | 16.9.6, 16.10.4, 16.11.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 16.9 to before 16.9.6; 16.10 to before 16.10.4; 16.11 to before 16.11.1 Fixed in 16.9.6, 16.10.4, 16.11.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.9.0 to before 16.9.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.9.0 to before 16.9.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.10.0 to before 16.10.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.10.0 to before 16.10.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:16.11.0:*:*:*:community:*:*:* | 16.11.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:16.11.0:*:*:*:enterprise:*:*:* | 16.11.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.9.0 to before 16.9.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.9.0 to before 16.9.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.10.0 to before 16.10.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.10.0 to before 16.10.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:16.11.0:*:*:*:community:*:*:* Versions 16.11.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:16.11.0:*:*:*:enterprise:*:*:* Versions 16.11.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 16.9.6, 16.10.4, 16.11.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 16.10.4, 16.11.1, 16.9.6
5 records Highest priority Priority MEDIUM 3 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2024-03753 Authentication Bypass by Assumed-Immutable Data in GitLabPriority MEDIUM 56
- TI-2024-02639 Inefficient Regular Expression Complexity in GitLabPriority MEDIUM 54
- TI-2024-01255 Authentication Bypass by Spoofing in GitLabPriority LOW 25
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 4 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2434
- 2026-10-03 Alias added: GHSA-gwr5-7mcm-726j
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-2434 · CVE Program
- CVE-2024-2434 · NVD
- FIRST EPSS
- GHSA-gwr5-7mcm-726j · GitHub Advisory Database · CC BY 4.0
- CVE-2024-2434 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences