Gutenberg Blocks by Kadence Blocks < 3.2.26 - Contributor+ Stored XSS
Priority MEDIUM 62CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Gutenberg Blocks by Kadence Blocks WordPress plugin before 3.2.26 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00427 37th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by the CNA and NVD
Fix Fixed Gutenberg Blocks by Kadence Blocks (Unknown): 3.2.26
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Gutenberg Blocks by Kadence Blocks | before 3.2.26 | 3.2.26 | Patch available | CNA |
- Gutenberg Blocks by Kadence Blocks VendorUnknown Affected before 3.2.26 Fixed in 3.2.26 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kadencewp:gutenberg_blocks_with_ai:*:*:*:*:*:wordpress:*:* | before 3.2.26 | Vulnerable | Kadence WP |
- cpe:2.3:a:kadencewp:gutenberg_blocks_with_ai:*:*:*:*:*:wordpress:*:* Versions before 3.2.26 Vulnerable ·Kadence WP
Remediation
- Fix · CNA Gutenberg Blocks by Kadence Blocks (Unknown) Fixed in 3.2.26
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2509
- 2026-10-03 Alias added: GHSA-w5wq-cvfc-3r8g
References
More Kadence WP Gutenberg Blocks With Ai vulnerabilities
- TI-2024-09858 Kadence Blocks < 3.2.54 - Admin+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-06384 Gutenberg Blocks with AI by Kadence WP < 3.2.39 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2025-18470 WordPress Kadence Blocks plugin <= 3.3.1 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2023-06366 Server-side request forgery in stellarwp Kadence Blocks — Page Builder Toolkit for… CVSS 3.1HIGH 8.5
- TI-2024-15542 WordPress Kadence Blocks plugin <= 3.2.19 - Server Side Request Forgery (SSRF) vulnerability CVSS 3.1HIGH 7.7
- TI-2024-16402 WordPress Gutenberg Blocks by Kadence Blocks plugin <= 3.2.25 - Server Side Request Forgery (SSRF) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-2509 · CVE Program
- CVE-2024-2509 · NVD
- FIRST EPSS
- GHSA-w5wq-cvfc-3r8g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences