My Sticky Bar < 2.6.8 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Floating Notification Bar, Sticky Menu on Scroll, Announcement Banner, and Sticky Header for Any WordPress plugin before 2.6.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Floating Notification Bar, Sticky Menu on Scroll, Announcement Banner, and Sticky Header for Any Theme | before 2.6.8 | 2.6.8 | Patch available | CNA |
- Floating Notification Bar, Sticky Menu on Scroll, Announcement Banner, and Sticky Header for Any Theme VendorUnknown Affected before 2.6.8 Fixed in 2.6.8 Patch available CNA
Remediation
- Fix · CNA Floating Notification Bar, Sticky Menu on Scroll, Announcement Banner, and Sticky Header for Any Theme (Unknown) Fixed in 2.6.8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2643
- 2026-10-03 Alias added: GHSA-gw62-7pm8-x49v
References
More premio My Sticky Bar vulnerabilities
- TI-2024-06602 My Sticky Bar < 2.7.3 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-03810 My Sticky Bar < 2.7.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-06444 My Sticky Bar <= 2.6.6 - Cross-Site Request Forgery to Sensitive Information Exposure CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-2643 · CVE Program
- CVE-2024-2643 · NVD
- FIRST EPSS
- GHSA-gw62-7pm8-x49v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences