Local privilege escalation in FlexNet Publisher
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-427.
Summary
A misconfiguration in lmadmin.exe of FlexNet Publisher versions prior to 2024 R1 (11.19.6.0) allows the OpenSSL configuration file to load from a non-existent directory. An unauthorized, locally authenticated user with low privileges can potentially create the directory and load a specially crafted openssl.conf file leading to the execution of a malicious DLL (Dynamic-Link Library) with elevated privileges.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA FlexNet Publisher (Flexera) Fixed in 2024 R1 (11.19.6.0)
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2658
- 2026-10-03 Alias added: GHSA-2795-pjw4-5495
- 2026-11-06 EPSS moved to the below the 50th percentile
- 2026-11-07 Priority changed: MEDIUM → LOW
References
More Flexera vulnerabilities
- TI-2026-68945 Authentication bypass in FlexNet Publisher lmadmin SOAP handler CVSS 4.0CRITICAL 9.3
- TI-2018-14211 Resource allocation without limits in Flexera Software LLC FlexNet Publisher CVSS 3.1CRITICAL 9.8
- TI-2026-03488 FlexNet Manager Suite Privilege Escalation Vulnerability CVSS 4.0HIGH 8.7
- TI-2021-18267 2FA bypass on the RISC Platform CVSS 4.0LOW 2.3
- TI-2020-09734 An elevated privileges issue related to Spring MVC calls impacts Code Insight v7.x… CVSS 3.1CRITICAL 9.9
- TI-2018-14212 A Denial of Service vulnerability related to adding an item to a list in lmgrd and vendor… CVSS 3.1HIGH 7.5
Sources
- CVE-2024-2658 · CVE Program
- CVE-2024-2658 · NVD
- FIRST EPSS
- GHSA-2795-pjw4-5495 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences