FooGallery < 2.4.15 - Author+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The FooGallery WordPress plugin before 2.4.15, foogallery-premium WordPress plugin before 2.4.15 does not validate and escape some of its Gallery settings before outputting them back in the page, which could allow users with a role as low as Author to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admin
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | FooGallery | before 2.4.15 | 2.4.15 | Patch available | CNA |
| Unknown | foogallery-premium | before 2.4.15 | 2.4.15 | Patch available | CNA |
- FooGallery VendorUnknown Affected before 2.4.15 Fixed in 2.4.15 Patch available CNA
- foogallery-premium VendorUnknown Affected before 2.4.15 Fixed in 2.4.15 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fooplugins:foogallery:*:*:*:*:-:wordpress:*:* | before 2.4.15 | Vulnerable | fooplugins |
| cpe:2.3:a:fooplugins:foogallery:*:*:*:*:premium:wordpress:*:* | before 2.4.15 | Vulnerable | fooplugins |
- cpe:2.3:a:fooplugins:foogallery:*:*:*:*:-:wordpress:*:* Versions before 2.4.15 Vulnerable ·fooplugins
- cpe:2.3:a:fooplugins:foogallery:*:*:*:*:premium:wordpress:*:* Versions before 2.4.15 Vulnerable ·fooplugins
Remediation
- Fix · CNA FooGallery (Unknown) Fixed in 2.4.15
- Fix · CNA foogallery-premium (Unknown) Fixed in 2.4.15
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2762
- 2026-10-03 Alias added: GHSA-q2px-mjvm-3h6f
References
More fooplugins Foogallery vulnerabilities
- TI-2023-23759 WordPress FooGallery Plugin <= 2.2.44 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-13819 WordPress FooGallery Plugin <= 2.2.35 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-06350 Best WordPress Gallery Plugin – FooGallery <= 2.4.16 - Authenticated (Contributor+) Directory Traversal CVSS 3.1HIGH 7.7
- TI-2024-11241 Cross-site scripting in fooplugins Gallery by FooGallery CVSS 3.1MEDIUM 6.4
- TI-2023-23770 WordPress FooGallery Plugin <= 2.2.44 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-01972 FooGallery <= 2.4.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via Gallery Custom URL CVSS 3.1MEDIUM 6.4
Sources
- CVE-2024-2762 · CVE Program
- CVE-2024-2762 · NVD
- FIRST EPSS
- GHSA-q2px-mjvm-3h6f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences