Call Now Button < 1.4.7 - Admin+ Stored XSS
Priority MEDIUM 53CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Call Now Button WordPress plugin before 1.4.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0067 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Call Now Button (Unknown): 1.4.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Call Now Button | before 1.4.7 | 1.4.7 | Patch available | CNA |
- Call Now Button VendorUnknown Affected before 1.4.7 Fixed in 1.4.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:callnowbutton:call_now_button:*:*:*:*:*:wordpress:*:* | before 1.4.7 | Vulnerable | Callnowbutton |
- cpe:2.3:a:callnowbutton:call_now_button:*:*:*:*:*:wordpress:*:* Versions before 1.4.7 Vulnerable ·Callnowbutton
Remediation
- Fix · CNA Call Now Button (Unknown) Fixed in 1.4.7
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2908
- 2026-10-03 Alias added: GHSA-x3cc-r2hp-r6x7
References
More Callnowbutton Call Now Button vulnerabilities
- TI-2022-01329 Call Now Button < 1.1.2 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-2908 · CVE Program
- CVE-2024-2908 · NVD
- FIRST EPSS
- GHSA-x3cc-r2hp-r6x7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences